Author Topic: ISIS installation problems (SOLVED)  (Read 6212 times)


  • Osiris (Active Member)
  • **
  • Posts: 17
ISIS installation problems (SOLVED)
« on: August 21, 2007, 01:43:15 PM »
I am new to ISIS and fairly new to Linux. I am having lot of difficulty installing ISIS2 and would be very grateful if you could help me.

I am using Suse 10.1.

I have down loaded ISIS2 and think I have set the variables correctly:

Current ISIS config settings

base kit (required)
  1) ISIS executables ........ isisr
  2) TAE  executables & src... data
  3) ISIS common data tree ... /tae
  4) PGPLOT executables & src. pgplot

dev  kit
  5) ISIS source tree ........ isistree
  6) NAIF executables & src... naifexec

data kits
  7) Clementine .............. clementine
  8) Cassini ................. IS NOT SET
  9) Galileo ................. IS NOT SET
 10) IMP - Pathfinder ........ IS NOT SET
 11) Lunar Orbiter ........... IS NOT SET
 12) Mars Odyssey............. IS NOT SET
 13) Mariner 9 ............... IS NOT SET
 14) Mariner 10 .............. IS NOT SET
 16) Mars Express ............ IS NOT SET
 17) Mars Global Surveyor .... IS NOT SET
 18) NEAR Shoemaker .......... IS NOT SET
 19) VIKING 1 & 2 ............ IS NOT SET
 20) Voyager ................. IS NOT SET

Modify Current ISIS configuration (exit/no/{yes=all} 1 2 3 ...)? [no] ->

I have set TAE with a '/' as shown in the instructions - I hope that is correct.

My ISIS2 directory looks like this:

terry@linux-etd9:~/isis2> ls -l
total 88
drwxr-xr-x 3 terry users    72 2007-08-21 20:50 data
-rw-r--r-- 1 terry users   357 2007-08-21 20:42 isis_cfg
-rw-r--r-- 1 terry users   543 2007-08-21 21:22 isis_cshrc
-rwxr-xr-x 1 terry users 59723 2006-07-20 00:17 isis_install
-rw-r--r-- 1 terry users 11455 2006-07-19 22:24 isis_install_guide.txt
-rw-r--r-- 1 terry users   591 2007-08-21 21:22 isis_profile
drwxr-xr-x 3 terry users    72 2007-08-21 20:42 isisr
-rw-r--r-- 1 terry users  1219 2005-06-15 16:22 quick_start.txt

The instructions tell me that I should put isis_cshrc and isis_profile into 'users .cshrc or .profile file or in a system-wide startup file'.

I cannot find a users '.cshrc or .profile' file and I am not sure which 'system-wide startup file' I should use.

I presume I should run isis_install but am not sure if I should run it before or after moving isis_cshrc and isis_profile.

I have spent ages on this and I don't think I'm going to resolve it myself so i would appreciate some assistance.



  • Isis Support Team
  • Isis (Extreme Power Member)
  • *****
  • Posts: 606
ISIS installation problems (SOLVED)
« Reply #1 on: August 28, 2007, 10:42:02 AM »
Hi Terry,

Lets start at the beginning:

There are several things wrong with your configuration, so I would wipe your installation directories clean and start again.

It looks like you ran the rsync command to get the isis_install script correctly, from your installation directory, run that command again:

    rsync -az .

Next, you want to run the script with the sync and makestartup parameters:

    ./isis_install sync makestartup

This will return the screen where you define your installation directories.  This is where it looks like you may have gone wrong.  Your definitions should be complete explicit paths.  Therefore, if you want to set isisr to ~/isis2, then define it that way.  You have it set to isisr, which will install isisr in a directory called isisr in your current working directory (in other words you installation directory structure will look like isisr/isisr) and will only work if you run ISIS from that current working directory.  So give the explicit path and leave off the ISIS installation directory:

    base kit (required)
       1) ISIS executables ........ ~/isis2
       2) TAE  executables ........ ~/isis2
       3) ISIS common data tree ... ~/isis2
       4) PGPLOT src & exe ........ ~/isis2

By the way, the tae reference in the installation guide is a typo.  TAE should be set just like any other kit and not with a leading "/".  If you do this, TAE will be installed in your root directory.  You don't need trailling "/" in any of the definitions.  You might want to look in the root directory to see if TAE got installed there from your last attempt.  If it is, you will want to delete it.

After you finish your definitions and you type "no" to the last "Modify Current ISIS configuration" question, the script will rsync the ISIS kits you have defined into the proper directories.  The advantage of this design is you can install different ISIS 2 "kits" (or directories) in different places on your system.

When you get done with this step you will have three files in your installation directory: isis_cfg (which defines yours setup direstories) and isis_profile and isis_cshrc (which uses isis_cfg to define your system environment).

Now, is you are using a bash or sh shell, use the isis_profile file, and if you are using a c or t shell, use the isis_cshrc file.  You can then "source" these files manually before you run ISIS in a given window.  To do this just type:

    . isis_profile        (for bashor sh shells)


    source isis_cshrc    (for c and t shells)

Or you can put them in your .cshrc or .profile file in your home directory and ISIS will automatically initialize in very window you open (make sure to place them after any IDL initializations).  They are hidden files, so to find them type:

    ls -al

If you are on a network and others need to see your setup, you could also put them in a system wide source file, but this is only for network setups.

This should get you started correctly.  Please let us know if you have further problems.

Good luck,

Jac Shinaman
U.S. Geological Survey - Astrogeology
2255 N. Gemini Dr.
Flagstaff, AZ 86001


  • Osiris (Active Member)
  • **
  • Posts: 17
Problem solved!
« Reply #2 on: August 31, 2007, 01:05:08 PM »
Hi Jac...

Thanks very much for your help. I have reinstalled ISIS2 in the correct directories and it is working now.

Thanks again,