Author Topic: isis_profile issue (SOLVED)  (Read 6438 times)

Wes

  • Osiris (Active Member)
  • **
  • Posts: 13
isis_profile issue (SOLVED)
« on: September 26, 2007, 07:44:15 AM »
So I have seemingly properly installed isis 2 on my Mac (G5 - intel, using bourne shell) but when I try to run

. isis_profile

to get the ball rolling, I get the error messges:

-bash: isis_profile: line 8: unexpected EOF while looking for matching `"'
-bash: isis_profile: line 34: syntax error: unexpected end of file

So, simple mistake on my part or do I need to modify the isis_profile script?

Here is the isis-profile script that I have:

# Put the commands below in your .profile file
# Place after IDL initializations (if you have IDL)

#
# BEGIN ISIS .profile commands
#
ISISR="1
export ISISR
TAE=/Users/pattegw1/isis2/tae
export TAE
ISISDATA=/Users/pattegw1/isis2/data
export ISISDATA
PGPLOT=/Users/pattegw1/isis2/pgplot
export PGPLOT
ISISCSSDATA=/Users/pattegw1/isis2/cssdata
export ISISCSSDATA
ISISGALDATA=/Users/pattegw1/isis2/galdata
export ISISGALDATA
ISISNEARDATA=/Users/pattegw1/isis2/neardata
export ISISNEARDATA
. $ISISR/sys/sh/isispgmdef
. $ISISR/sys/sh/3rdparty_path.sh
export TAE
. $TAE/bin/sh/taesetup
. $TAE/bin/sh/taesetupclassic
PATH=${PATH}:$TAEBIN
export PATH
alias tae='taetm'
#
# END   ISIS .profile commands
#

Wes

  • Osiris (Active Member)
  • **
  • Posts: 13
isis_profile issue (SOLVED)
« Reply #1 on: September 27, 2007, 07:55:21 AM »
I am assuming the problem is with the

"1

at the top of the isis_profile.  It is listed as a subdirectory in my isis2 directory (which reads like this)

"1                      
isis_cshrc              
neardata
cssdata                
isis_install            
pgplot
data                    
isis_install_guide.txt  
quick_start.txt
galdata                
isis_profile            
tae
isis_cfg                
isisr

I just need to know if that type of directory is even supposed to be there or if I should just delete it and a chalk it up to poor typing on my part during the setup.

Wes

  • Osiris (Active Member)
  • **
  • Posts: 13
isis_profile issue (SOLVED)
« Reply #2 on: September 27, 2007, 08:00:16 AM »
Ok, fixed it.  The problem was with the "1 in the isis_profile.  Somehow the makestartup routine must have taken one of my number responses and used it to set the ISISR= destination.

works now.