Author Topic: pc2d error (SOLVED)  (Read 4724 times)

nafiseh

  • Osiris (Active Member)
  • **
  • Posts: 21
    • Email
pc2d error (SOLVED)
« on: June 09, 2011, 01:11:39 AM »
hello,

I've installed ISIS 2 in ubuntu 10.4 with IDL 7.0. I have a problem when I want to run pc2d .I see this message :

[UOPENLOG-OPENFAIL] (-1) unable to open session logging file « print.prt »
[USTDINIT-OPNLOG] (-2) can’t open log file

and also for another command like zero, ..... and commands in IDL for example cv!
but I can run qview!

I read another similar post here, about rad2isis. but unfortunately I cannot handle my problem.

It seems my problem is a kind of read/write permission, maybe since I am not familiar with linux, I am not able to solve it!

regrades,
nafiseh
« Last Edit: September 29, 2011, 07:29:35 AM by Tracie_Sucharski »

nafiseh

  • Osiris (Active Member)
  • **
  • Posts: 21
    • Email
Re: pc2d error
« Reply #1 on: June 10, 2011, 07:23:06 AM »
I solved the problem, as I said , It was a kind of linux problem. I just typed :
Sudo chmod 777 /home/my laptopname

so it allows isis to create print.prt :-)

regards
nafiseh

JohnVV

  • Isis (Extreme Power Member)
  • *****
  • Posts: 287
    • Email
Re: pc2d error (SOLVED)
« Reply #2 on: January 02, 2014, 01:31:51 AM »
Yes i know it is an old thread
i was googling photoclinometry( and hit here ) and the above "777'ing" a folder was a rather recent topic ( and scolding to that OP over on Linuxquestions.org)

777
-- not good
For the next people that come across this thread

isis2 is older and even RHEL 5.10 will through a SELinux  "temper tantrum "  if one runs
Code: [Select]
cd /home
chmod -R 777 YourHomeFolder
that is a big NO-NO and will cause a lot of problems
SE will prevent you from loging in to the system until you Fix your home folder
-- you basically create a NEW user to fix it

and if one was to do that on a system folder --- say /etc ,/usr/opt, /usr/bin
SELinux will STOP the boot process until it is fixed
a rather nasty process with using rpm ( and it is easier to reinstall the operating system )

so the next person that hits this thread in a google search
DO NOT use 777 !