Project

General

Profile

Crash #2060

qnet - crashes when changing PointType from Constrained to Fixed

Added by Lynn Weller over 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Applications
Impact:

Changing a point from a constrained to a fixed point while working on a image should not crash

Software Version:
Test Reviewer:

Description

While working with a ground (constrained) point, qnet will crash when I change the point type to Fixed. An error dialog pops up about the serial number not being unique, I click ok, try to do something else, then it crashes.

Small data set to play with: /work/users/lweller/Isis3Tests/Qnet/MiscSegFaultsWithGround/
Extracted.lis
Extracted.net
open ground source Shade_Mola_Radius.cub
open radius source Mola_Radius.cub

  • open constrained point in editor (or add a new one and save it)
  • change point type from constrained to fixed (constrained to free seems ok)
  • click ok in error dialog box
  • crash

this first happened with a very large messenger network, so it's not data specific.

I have no idea when this started.

QnetCrashMessage_Constrained2Fixed.png View (13.3 KB) Lynn Weller, 2014-04-09 12:41 PM

History

#1 Updated by Lynn Weller over 4 years ago

This error does not occur under the isis3production2013-10-01 version of isis which is the version saved prior to the rings merge.
I have gone back as far as I can with isis versions including the last public release isis3.4.5 and confirmed the crash occurs there as well. I'm thinking this is a rings issue that we haven't caught due to lack of app tests for qnet and the fact that we don't used fixed as often as constrained.

#3 Updated by Tammy Becker over 4 years ago

  • Status changed from New to Acknowledged

#4 Updated by Lynn Weller over 4 years ago

  • Priority changed from High to Normal

Changed the priority to normal bacause I can work around this when necessary by using cneteditor. If the moderator(s) thinks it should go back to High for any reason, please do so.

#5 Updated by Tammy Becker about 4 years ago

  • Priority changed from Normal to High
  • Target version set to 3.4.8 (FY15 R1 2014-11-26 Nov)

Modified user priority from Normal to High. This bug is impacting the user and the control network workshop demos.

#7 Updated by Stuart Sides about 4 years ago

  • Assignee set to Ian Humphrey

#10 Updated by Stuart Sides almost 4 years ago

  • Target version changed from 3.4.8 (FY15 R1 2014-11-26 Nov) to 3.4.9 (FY15 R2 2015-03-26 Mar)

#14 Updated by Stuart Sides almost 4 years ago

  • Assignee deleted (Ian Humphrey)

#15 Updated by Moses Milazzo over 3 years ago

  • Assignee set to Ian Humphrey

Added to FY15Q3 account as top priority fix.

#16 Updated by Moses Milazzo over 3 years ago

From testing, it appears as though qnet crashes when changing from Fixed to Constrained in exactly the same way as changing from Constrained to Fixed. Both changes appear to be calling the AddMeasure method in the ControlPoint class. Still digging to figure out why it's doing that instead of just changing the PointType.

#17 Updated by Moses Milazzo over 3 years ago

  • Assignee deleted (Ian Humphrey)

#18 Updated by Stuart Sides over 3 years ago

  • Target version changed from 3.4.9 (FY15 R2 2015-03-26 Mar) to 3.4.10 (FY15 R3 2015-07-23 Jul)

#19 Updated by Stuart Sides over 3 years ago

  • Assignee set to Ian Humphrey

#20 Updated by Ian Humphrey over 3 years ago

  • Status changed from Acknowledged to In Progress
  • Impact updated (diff)

#21 Updated by Ian Humphrey over 3 years ago

  • Status changed from In Progress to Resolved

Modified the logic related to setting the point type on a ground measure. Now when switching between Fixed and Constrained types (and vice versa), the ground measure is no longer added as new measure (causing an error with serial numbers not being unique).

To test, setisis /work/projects/isis/latest/m02060/isis

We tested switching from fixed/constrained to free, free to fixed/constrained, and constrained to fixed (and vice versa) and being sure to save the point as well.

#22 Updated by Lynn Weller over 3 years ago

  • Status changed from Resolved to Closed

I can't break it! Went from Fixed to Constrained and back. Also swapped to Free. Moved measures, changed point type saved and did a variety of other things without any problems. Looks good!

Also available in: Atom PDF