Project

General

Profile

Bug #2080

qnet - Unexpected change with ground source between recent ISIS versions

Added by Lynn Weller almost 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
High
Category:
Applications
Impact:
Software Version:
Test Reviewer:

Description

The latest version of qnet isis3production2014-05-06 is behaving oddly in regard to Ground Source files, but works as expected under the previous version of isis isis3production2014-04-29.

  1. load a network with ground points.
  2. load a ground point
  3. load a ground source via Open Ground Source (in my case, the ground source comes from various Viking Oribiter level 1 images)
  4. make adjustments as needed.
  5. close ground source (I do this at this point because there is a high probability that the next ground point I work on will have a completely different Viking image as it's ground source)
  6. load a new ground point A warning box appears saying the point does not exist on the ground source (which is closed at this point) and a ground point will not be created. Click ok. A warning box appears saying "cannot find ground file in list of files, make sure correct ground source file was loaded." Click ok. The VO image are not in the file list because they can not be bundled with the themis data. This has not been an issue before this version.
  7. The point is loaded, but in the Qnet Tool it shows that there is a Ground Source file loaded - the one that was closed in step 5.

I repeat the above under the previous version of isis isis3production2014-04-29 and after closing the ground source file (step 5), I get no warnings at all. When I load a new point the Ground Source File in the Qnet Tool is empty, as it should be.

What has changed and why?? I'm worried about my ground points being loaded/saved properly since it seems like the ground source isn't really being closed, despite closing it.
I looked back through email announcements and I can't find any indication that qnet changed between versions. The only changes I see in regard to the 05-06 version has to do with spiceinit and the spice web server.

I'll use the 04-29 version in the meantime.

There is data this can be demonstrated with under /work/users/lweller/Isis3Tests/Qnet/GroundNotClosing/. Sorry it's a big net - I don't have anything smaller. The image list is Iapygia_NightIR_Ground_Merge.lis. The file constrained_PtId_VOReference.lis has ground pointid in column 1 and the corresponding Viking Orbiter ground source image in column 2. I grep out the point id to find out which VO image to load as my ground source file. In qnet, if you filter on Jigsaw Errors > 5 you will get ground points in the list. Load h0047_0000_1 and /work/projects/themis_control/VO_Lev1/f623a74.lev1_slo.cub as the ground source. Close the ground source, then select h0532_0000_1 - you will get the warning. It's VO image is /work/projects/themis_control/VO_Lev1/f623a74.lev1_slo.cub of up want to load it.

History

#1 Updated by Lynn Weller almost 4 years ago

  • Subject changed from qnet - Unexpected change between recent ISIS versions to qnet - Unexpected change with ground source between recent ISIS versions

#2 Updated by Lynn Weller almost 4 years ago

  • Status changed from New to Closed
  • Target version set to N/A

Tracie attempted to reproduce my problem under a variety of scenarios (including running the test directly on the disk my data are stored) and was not able to. I found that if I tried to reproduce the problem under /work/users/lweller/Isis3Tests/Qnet/GroundNotClosing/ while using isis3production2014-05-06 I wasn't able to - everything worked fine. But when I used qnet under this version of isis on /work/projects/themis_control/lweller/Iapygia/NightIR/GroundNet/ it always produced warnings and the ground never got cleared out. On Thursday May 8, the server that hosts /work/projects/themis_control/ had an outage which may have corrupted the config files for qnet, that I most likely had open at the time. Tracie suggested I remove /home/lwelller/.Isis/qnet and see if that makes a difference. It fixed my problem. It doesn't make sense, but it worked. I'm closing the post and will reopen if necessary.

#3 Updated by Stuart Sides over 3 years ago

  • Assignee set to Tracie Sucharski

Set the some fields after closing to allow searches to pick this ticket up properly.

#5 Updated by Stuart Sides about 1 year ago

  • Target version changed from N/A to 3.4.11 (FY16 R1 2015-10-28 Oct)

Also available in: Atom PDF