Project

General

Profile

Bug #2151

map2map error when missing Scale keyword

Added by Kristin Berry about 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
David Miller
Category:
Applications
Impact:

No negative impact is expected as a result of this solution.

Software Version:
Test Reviewer:

Description

When map2map with matchmap=yes or pixres=map is run with an input map missing the Scale keyword, map2map throws an error:
ERROR PVL Keyword [Scale] does not exist in [Group = Mapping]

Since PixelResolution and Scale are both legitimate measures of resolution on their own, map2map shouldn't throw an error about this. Especially since, if you have exactly the same inputs, and change from pixres=map to pixres=mpp and copy-and-paste the value from the PixelResolution mapping label into map2map, it works fine.

To reproduce:
In: /work/projects/eros_isis/kberry/testing
Run: map2map from=output.cub map=outputMap.pvl to=outputOcentric.cub matchmap=yes interp=bilinear
or: map2map from=output.cub map=outputMap.pvl to=outputOcentric.cub pixres=map interp=bilinear

These will both throw errors.

Compare with:
map2map from=output.cub map=outputMap.pvl to=outputOcentric.cub pixres=mpp resolution=1.0 interp=bilinear

This is effectively the same thing, but runs without error.

History

#1 Updated by Tammy Becker about 4 years ago

  • Status changed from New to Acknowledged

#4 Updated by Stuart Sides about 3 years ago

  • Status changed from Acknowledged to Assigned
  • Assignee set to David Miller

#5 Updated by David Miller about 3 years ago

  • Status changed from Assigned to In Progress
  • Target version set to 3.4.11 (FY16 R1 2015-10-28 Oct)

#6 Updated by David Miller about 3 years ago

  • % Done changed from 0 to 50

#7 Updated by David Miller about 3 years ago

Apparent bug identified on map2map.cpp line 121: possible unintentional semicolon removes boolean statement from controlling a scoped statement. Unable to reproduce error from reporter's test area to verify solution. Halting work temporarily. Will resume when reporter can recreate the problem. Will attempt to verify solution when able to recreate problem.

#8 Updated by Kristin Berry about 3 years ago

It should be reproducible now. I'd left the Scale keyword in output.cub and map2map was picking it up from there.

#9 Updated by David Miller about 3 years ago

  • % Done changed from 50 to 60

Able to recreate error. Now attempting to verify solution.

#10 Updated by David Miller about 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 60 to 100

Verified solution. Awaiting reporter testing.

#11 Updated by David Miller about 3 years ago

  • Impact updated (diff)

#12 Updated by Kristin Berry about 3 years ago

In the future, before resolving, could you "make install" the application you modified? It makes it a little easier to test, because then you can just setisis /work/projects/isis/latest/m02151 and then run map2map instead of using the full path to your modified application /work/projects/isis/latest/m02151/isis/src/base/apps/map2map/map2map

#13 Updated by Kristin Berry about 3 years ago

  • Status changed from Resolved to Closed

Looks good, thanks!

#14 Updated by David Miller about 3 years ago

New test "keywords" written to exercise code changed.

Also available in: Atom PDF