Project

General

Profile

Feature #2209

Provide support for OSX 10.10

Added by Stuart Sides almost 3 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Block
Assignee:
Category:
Infrastructure
Impact:

This change will require ISIS to use Qt 5.4.x. This may modify the look of some GUI elements. Moveing to Qt 5.4.x requires changing some code in much of ISIS. The potential for making errors is very real. Please test as much as you can.

Software Version:
Test Reviewer:

Description

Current ISIS build for Mac OSX 10.6 and 10.8 are having problems running on 10.9 and 10.10. Making 10.10 work is expected to require upgrading many of the third party libraries ISIS uses. This will ripple through the other supported OSs as well.


Related issues

Related to ISIS - Question #4481: Connecting to rysnc Closed

History

#2 Updated by Stuart Sides over 1 year ago

Hi,

Yes, this is still a problem. We only have the 10.9 build at the moment. We are working on a 10.11 build that should be ready soon.

Stuart

#3 Updated by Stuart Sides about 1 year ago

  • Target version changed from 3.4.9 (FY15 R2 2015-03-26 Mar) to 214

10.10 will be skipped. We are porting to 10.11 and may be able to support it in the Jan 2017 release.

#6 Updated by Makayla Shepherd about 1 year ago

When testing the GUIs for OSX 10.11 I got terminal output.

2016-10-12 14:50:30.129 qview[99346:62049812] NSWindow does not support utility styleMask 0x10
2016-10-12 14:50:30.164 qview[99346:62049812] CFPasteboardRef CFPasteboardCreate(CFAllocatorRef, CFStringRef) : failed to create global data
2016-10-12 14:50:30.164 qview[99346:62049812] CFPasteboardRef CFPasteboardCreate(CFAllocatorRef, CFStringRef) : failed to create global data
2016-10-12 14:50:38.617 qview[99346:62049812] CFPasteboardRef CFPasteboardCreate(CFAllocatorRef, CFStringRef) : failed to create global data
2016-10-12 14:50:38.617 qview[99346:62049812] CFPasteboardRef CFPasteboardCreate(CFAllocatorRef, CFStringRef) : failed to create global data

This terminal output is not allowed and must be fixed before OSX 10.11 can be supported.

#7 Updated by Tammy Becker about 1 year ago

#8 Updated by Kelvin Rodriguez about 1 year ago

The CFPasteboardRef warnings were being caused by a process called pboard that runs as a service in MacOS. Pboard handles all the copying and pasting for the operating system. It has become somewhat unstable in 10.11 and occasionally creating warnings such as the ones mentioned above. Restarting the service clears the issue.

#9 Updated by Stuart Sides 12 months ago

  • Status changed from In Progress to Closed

The 10.11 build is ready for beta release, and will be released when we create the beta for all supported platforms.

#10 Updated by Stuart Sides 10 months ago

  • Target version changed from 214 to 3.5.0 (FY17 2017-01-25 Jan)

Also available in: Atom PDF