Project

General

Profile

Bug #2258

campt -- default allowoutside=TRUE is not being applied without including allowoutside=TRUE in command.

Added by Moses Milazzo over 2 years ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Applications
Target version:
Impact:

Low impact expected, since the expected behavior has been established.

Software Version:
Test Reviewer:

Description

Reported to me via email.

Hi Moses,

I can't post a new topic to the ISIS support forum. I keep getting the error "The specified URL cannot be found". I thought I'd let you know that I think I found a bug in campt. I'll keep trying to post it to the forum, but here is what I've been trying to post:

The default allowoutside parameter doesn't seem to be defaulting to TRUE unless explicitly set in command line.

When I don't include allowoutside=TRUE in the command line, campt fails if the lat/lon is outside the valid pixels, even though the campt output states allowoutside is set to true.

cnode05:../~/campt_test 6:50 % campt from= ESP_041100_0990_RED5.balance.cub to= ESP_041100_0990.campt.pvl type=GROUND latitude= -80.728 longitude= 155.028 format=PVL
Object = campt
IsisVersion = "3.4.9.6114 stable | 2015-03-26"
ProgramVersion = 2015-03-03
ProgramPath = /opt/usgs/isis/bin
ExecutionDateTime = 2015-05-22T06:50:58
HostName = cnode05
UserName = audrie
Description = "Computes geometric and photometric information at a
given pixel location"

Group = UserParameters
FROM = ESP_041100_0990_RED5.balance.cub
USECOORDLIST = FALSE
TO = ESP_041100_0990.campt.pvl
FORMAT = PVL
APPEND = TRUE
ALLOWOUTSIDE = TRUE
TYPE = GROUND
LATITUDE = -80.728
LONGITUDE = 155.028
End_Group

Group = Error
Program = campt
Code = 1
Message = "Requested position does not project in camera model; not inside
cube"
File = CameraPointInfo.cpp
Line = 258
End_Group
End_Object
End

When I explicitly set it to TRUE in the command line, it completes successfully.

cnode05:../~/campt_test 6:50 % campt from= ESP_041100_0990_RED5.balance.cub to= ESP_041100_0990.campt.pvl type=GROUND latitude= -80.728 longitude= 155.028 format=PVL allowoutside=TRUE
Object = campt
IsisVersion = "3.4.9.6114 stable | 2015-03-26"
ProgramVersion = 2015-03-03
ProgramPath = /opt/usgs/isis/bin
ExecutionDateTime = 2015-05-22T06:53:17
HostName = cnode05
UserName = audrie
Description = "Computes geometric and photometric information at a
given pixel location"

Group = UserParameters
FROM = ESP_041100_0990_RED5.balance.cub
USECOORDLIST = FALSE
TO = ESP_041100_0990.campt.pvl
FORMAT = PVL
APPEND = TRUE
ALLOWOUTSIDE = TRUE
TYPE = GROUND
LATITUDE = -80.728
LONGITUDE = 155.028
End_Group

Group = GroundPoint
Filename = ESP_041100_0990_RED5.balance.cub
Sample = -0.9578551128368
Line = 12491.781840171
PixelValue = Null
RightAscension = 332.80211220887
Declination = 56.623087599345
PlanetocentricLatitude = -80.728
PlanetographicLatitude = -80.834971287743
PositiveEast360Longitude = 155.028
PositiveEast180Longitude = 155.028
PositiveWest360Longitude = 204.972
PositiveWest180Longitude = -155.028
BodyFixedCoordinate = (-493.88768328888, 230.00983505807,
-3337.2470446277)
LocalRadius = 3381426.829728
SampleResolution = 0.49798337048358
LineResolution = 0.49798337048358

Spacecraft Information

SpacecraftPosition = (-507.41666572893, 268.70474167253,
-3582.736075901)
SpacecraftAzimuth = 359.14938954746
SlantDistance = 248.88791396256
TargetCenterDistance = 3628.4530726494
SubSpacecraftLatitude = -80.895150478762
SubSpacecraftLongitude = 152.09634482987
SpacecraftAltitude = 247.70511948881
OffNadirAngle = 6.7681373222046
SubSpacecraftGroundAzimuth = 248.90740340459

Sun Information

SunPosition = (-44613181.148847, 216414484.4123,
-38224700.153792)
SubSolarAzimuth = 54.998340050848
SolarDistance = 1.4989923030783
SubSolarLatitude = -9.8144529031102
SubSolarLongitude = 101.64817585069
SubSolarGroundAzimuth = 304.94486326995

Illumination and Other

Phase = 70.793618456786
Incidence = 74.756572010191
Emission = 7.2651505421803
NorthAzimuth = 109.89294362173

Time

EphemerisTime = 483970077.75495
UTC = 2015-05-04T00:06:50.5695013
LocalSolarTime = 15.558654948301
SolarLongitude = 336.39461344432
End_Group

Group = Accounting
ConnectTime = 00:00:00.0
CpuTime = 00:00:00.2
End_Group
End_Object
End

No rush on this. It can be worked around by explicitly setting in command line. Just thought I would report it.

History

#1 Updated by Moses Milazzo over 2 years ago

  • Status changed from New to Acknowledged

#2 Updated by Tammy Becker over 1 year ago

  • Category set to Applications

--------- Forwarded message ----------
From: Michael Aye Michael.Aye@lasp.colorado.edu
Date: Fri, Apr 1, 2016 at 10:36 AM
Subject: Addition to campt acknowledged issue #2258
To: Moses Milazzo moses@usgs.gov

Thanks for forewarding!

Here's how I see the error modes of the campt option parser.

2 problems with how campt treats the allowoutside option:

The docs state that default is True, while the default seems to be False:

(stable)% campt from= G11_022679_0981_XN_81S218W.cal.cub format=pvl type=image sample=9000 line=2000
ERROR Requested position does not project in camera model; not inside cube.
https://www.dropbox.com/s/v8jc9oe8oe0rqky/Screenshot%202016-04-01%2011.03.55.png?dl=0

When trying to set it to false manually, it still allows it:

(stable)% campt from= G11_022679_0981_XN_81S218W.cal.cub format=pvl type=image sample=9000 line=2000 allowoutside=false
Group = GroundPoint
Filename = G11_022679_0981_XN_81S218W.cal.cub
Sample = 9000.0
Line = 2000.0
PixelValue = Null
RightAscension = 332.47708369972
Declination = 38.856035929923
PlanetocentricLatitude = -82.332403203616
PlanetographicLatitude = -82.421348466591
PositiveEast360Longitude = 147.9111249983
PositiveEast180Longitude = 147.9111249983

#3 Updated by Stuart Sides 6 months ago

  • Status changed from Acknowledged to Assigned
  • Assignee set to Kaj Williams

#4 Updated by Kaj Williams 6 months ago

  • Status changed from Assigned to In Progress

#5 Updated by Kaj Williams 6 months ago

  • Test Reviewer set to Stuart Sides

#6 Updated by Kaj Williams 6 months ago

  • Status changed from In Progress to Resolved
  • Impact updated (diff)

Fixing these issues caused the old "pointlist_error" test to break. It seems to be due to the old default behavior (complaining about some points being out of bounds) having changed, which it shouldn't be complaining about any longer. In other words, the old "pointlist_error" test was wrong, and it has been corrected.
Please make sure that the test still makes sense.

Built on prog21.

#7 Updated by Stuart Sides 6 months ago

  • Target version set to 3.5.1 (Sprint 1)
  • Test Reviewer deleted (Stuart Sides)

#8 Updated by Makayla Shepherd 6 months ago

  • Test Reviewer set to Robert Sucharski

#9 Updated by Robert Sucharski 6 months ago

Tested using the CTX image listed in ticket, the campt run was successful when run with defaults and a point outside the image area. I also placed the test image in "/work/projects/usertests/UserTestPlans/Apps/campt/m02258/" if more testing is required.

#10 Updated by Moses Milazzo 6 months ago

  • Status changed from Resolved to Closed

#11 Updated by Stuart Sides 4 months ago

  • Target version changed from 3.5.1 (Sprint 1) to 3.5.1 (2017-08-08 Aug)

Also available in: Atom PDF