Project

General

Profile

Bug #2266

qnet - cube list not re-filtering when creaing a new point and navigating by points

Added by Makayla Shepherd over 3 years ago. Updated 6 months ago.

Status:
Feedback
Priority:
Normal
Assignee:
Category:
Applications
Target version:
-
Impact:

Minimal - QnetNavTool was the only thing affected by this change. (and perhaps, qnet, indirectly).

Software Version:
Test Reviewer:

Description

Steps to reproduce
filter the cubes by number of points associated with the cube
open a cube that is just within the filter range (Example: filter by less than 23 points associated with the cube, open a cube with 22 points)
switch navigation type to points
create a point on the cube you opened
save the point
switch navigation type to cubes
cube should not be in the list anymore but still is

The fix to Bug #2144 caused this bug, as switching between the navigation types with filtered data simply calls up the previous filtered list. While saving or creating a new point will run filter() on the current navigation type (so if the navigation type is points only points will be re-filtered), it only runs the filter that navigation tool filter widget is currently on even if there are multiple filters, and it only runs the filter on the already filtered list (which does not contain the new point, so even if the new point allows to a cube (ie enough points) to meet all the criteria to be apart of the filtered list, it will not be included).


Related issues

Related to ISIS - Bug #2267: qnet - when navigating by cubes, new point created does not show up after switching navigation type to points Feedback
Related to ISIS - Bug #2144: qnet - Filter being reset when navigation type changed Closed 2014-07-24
Related to ISIS - Bug #5419: Qnet causes error popup when creating a point with blank point filter selected Acknowledged

History

#1 Updated by Makayla Shepherd over 3 years ago

  • Related to Bug #2267: qnet - when navigating by cubes, new point created does not show up after switching navigation type to points added

#2 Updated by Makayla Shepherd over 3 years ago

  • Related to Bug #2144: qnet - Filter being reset when navigation type changed added

#3 Updated by Moses Milazzo over 3 years ago

  • Status changed from New to Acknowledged

#4 Updated by Adam Goins 6 months ago

  • Assignee set to Adam Goins

#5 Updated by Adam Goins 6 months ago

  • Status changed from Acknowledged to In Progress

#6 Updated by Adam Goins 6 months ago

  • Status changed from In Progress to Resolved
  • Impact updated (diff)

QnetNavTool now has two additional member variables that keep track of the active filter for both point, and cubes.
Whenever a change is made, these member variables are updated and QnetFilter->filter() is called on both whenever a change is made to either, which updates both simultaneously with respect to the implemented change.

Testing can be done in /work/projects/isis/latest/m02266_m02267 where these changes have been built on prog24 for testing.
There's a folder in this directory called "testing" where there's a CASSIS control network that I was using for testing.

You can filter cubes by number of points, and select cubes with less than 8 points to pull up 4 cubes to test this out with if you decide to use the network I've provided.

#7 Updated by Lynn Weller 6 months ago

  • Status changed from Resolved to Feedback

I've tested the changes and see that the cube will disappear from from filter list when it exceeds the filtered point count, but there are other filter related bad things happening that I haven't seen before.

When I follow Makayla's instructions under the current beta (and the one prior), I get error messages after I filter on the cubes then switch the navigation over to points and create a new point - "Error, Error value must be entered". I click OK in the dialog box, but it pops up again after I Save Point (which does not show up in the list of points after I've added it....I think I've seen this bug for quite some time). I sometimes see this particular message when I've filtered on something and hit the Return key instead of clicking Filter, but I'm not filtering in these cases so I shouldn't be seeing this. I don't know when this behavior was introduced (well, it's present in isis3.5.1...I don't ever filter on number of points in cube, so I guess I haven't run into it before now).

So are neither one of you seeing the error? The only way I don't get the message to go away is if I "Show All" (doesn't matter whether I'm under cubes or points). The filtering in general is a bit touchy and has been for some time due to changes made years ago to fix some other filtering problems. The entire widget probably needs revisiting.

#8 Updated by Adam Goins 6 months ago

Hey Lynn, I have seen this error.

It looks like it's caused because when you're on the "Point" filter option and create a new point a signal is emitted to filter the list.
When "Point" filter is selected, there's a checkbox item "Greater than (overcontrolled)" option selected by default and when filter() is called
it thinks that you're trying to filter points by "Greater than (overcontrolled)" because it's selected at the time the point is created but fails because no value is supplied to that input field.

Do you know if a ticket exists for this behavior already? I haven't seen one personally but if it exists I'd happily pick it up.

#9 Updated by Lynn Weller 6 months ago

Hey Lynn, I have seen this error.

It looks like it's caused because when you're on the "Point" filter option and create a new point a signal is emitted to filter the list.
When "Point" filter is selected, there's a checkbox item "Greater than (overcontrolled)" option selected by default and when filter() is called
it thinks that you're trying to filter points by "Greater than (overcontrolled)" because it's selected at the time the point is created but fails because no value is supplied to that input field.

Do you know if a ticket exists for this behavior already? I haven't seen one personally but if it exists I'd happily pick it up.

Huh, so when something was "fixed" in regard to qnet filtering, one thing that was modified was the default "Filter" on Jigsaw Errors under the Points navigation tab. I can't remember why, but the default was changed to Modify Point. This has been quite annoying because the Filer default was that way for years and I haven't been able to shake the habit of entering something under the points filter and just hitting return to filter it. Now when I do that I either get a warning (when qnet is first opened and no points are highlighted) or it automatically loads a highlighted point. From what you're saying, some of that functionality is still in place and creating a conflict and error/warning message in the process?

Maybe two different problems going on. As for the error messages that are popping up via Makayla's sequence of events, yes we should probably fix it, and no, there is no post for it (I think her steps are a little unusual which is likely why Tammy and I have not encountered/reported it), but, I'd rather these posts get resolved and checked in before jumping into another qnet post. It's too touchy a program and fixing things tends to break other things by accident.

#10 Updated by Adam Goins 5 months ago

  • Related to Bug #5419: Qnet causes error popup when creating a point with blank point filter selected added

Also available in: Atom PDF