Project

General

Profile

Bug #2272

isis2fits - crashes with 'failed to convert string'

Added by Tammy Becker over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Applications
Impact:

No negative impact is expected as a result of this fix.

Software Version:
Test Reviewer:

Description

Reported by Dale Noss:
https://isis.astrogeology.usgs.gov/IsisSupport/index.php/topic,3951.0.html

Stuart confirmed that this is the known 'strings' error that needs to be fixed as it is encountered by applications.

History

#1 Updated by Tammy Becker over 2 years ago

External Post details:
I've tried to write FITS files from camera cubes of MRO/CTX, Dawn/FC and Mercury/MDIS.
In each case, I'm able to write a simple (NOMINAL) FITS file. However, when I use the
"info=all" option, isis2fits produces an error that it "Failed to convert string [InstrumentId]
to an integer". It's unclear why " InstrumentId = MDIS-NAC" needs conversion at all,
as FITS supports strings in the header.

isis2fits from=/tmp/EN1053312704M.cal.cub to=/tmp/EN1053312704M.cal.fits info=all

#3 Updated by Stuart Sides over 2 years ago

  • Status changed from Acknowledged to Assigned
  • Assignee set to David Miller
  • Target version set to 3.4.11 (FY16 R1 2015-10-28 Oct)

#4 Updated by David Miller over 2 years ago

  • Status changed from Assigned to In Progress
  • % Done changed from 0 to 10

#5 Updated by David Miller over 2 years ago

Unable to reproduce error with own data. Cube used in /tmp is no longer there. Ask Reporter for data used to reproduce the error.

#6 Updated by David Miller over 2 years ago

  • % Done changed from 10 to 30

Found other test data that caused error. Made fixes, but would still like to check against other data, ie the file that cause the error reported in the ticket. Waiting to contact reporter to ask about test data mentioned in original ticket before marking resolved. Additional testing is needed.

#7 Updated by Tammy Becker over 2 years ago

The test cube of the external reporter:
/work/users/tbecker/IsisTesting/M02272_isis2fits/EN1053312704M.lev1.cub

#8 Updated by David Miller over 2 years ago

  • % Done changed from 30 to 90

When this bug happens, InstrumentId, SpacecraftName, TargetName, StartTime, StopTime, and ExposureDuration are not given fits labels because the application halts. With this fix, all those labels should now be available. Will run some tests and recommend new tests be added to strengthen this correction before resolving.

#9 Updated by David Miller over 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100
  • Impact updated (diff)

Built on prog6 (Scientific Linux 6.5) and ready for immediate testing.

#10 Updated by John Shinaman over 2 years ago

The program has been tested successfully. The test data is located in /work/users/jshinaman/Support/RM_2272. I will follow up with David about new app tests.

#11 Updated by John Shinaman over 2 years ago

The app tests for this program are deficient by ISIS standards. Meets scope by 62%, line by 63%, function by 67%.

#12 Updated by Tammy Becker over 2 years ago

  • Status changed from Resolved to Closed

#13 Updated by Kristin Berry over 2 years ago

  • Assignee changed from David Miller to Stuart Sides

This is closed, but there is no checked-in code associated with it (I checked in SVN.)

#14 Updated by Kristin Berry over 2 years ago

  • Status changed from Closed to Resolved

#15 Updated by Kristin Berry over 2 years ago

  • Status changed from Resolved to Feedback

Changing to Feedback, so this is visible in your list.

#16 Updated by Stuart Sides over 2 years ago

  • Assignee changed from Stuart Sides to Tyler Wilson

#17 Updated by Tyler Wilson over 2 years ago

  • Status changed from Feedback to In Progress

#18 Updated by Tyler Wilson over 2 years ago

  • Status changed from In Progress to Resolved

#19 Updated by John Shinaman over 2 years ago

The program has been tested successfully. The test data are located in /work/users/jshinaman/Support/RM_2272.

#20 Updated by Tammy Becker over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF