Project

General

Profile

Feature #247

Software steering committee priority improvements to photomet need to be completed in FY11

Added by Laszlo Kestay about 8 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Block
Assignee:
Category:
Applications
Target version:
Impact:
Software Version:
Test Reviewer:

Description

Improvements to photomet was identified as one of the major priorities for the remainder of FY11 (#96). Specific needs include streamlined interface, "empirical" photometric functions, and wavelength dependent corrections. A tiger team consisting of Janet B., Randy, Tammy, Tom has developed a general plan. Janet and Sharmila will do the programming work on this task.

Photomet_design_notes.doc (49 KB) Redmine Admin, 2011-07-26 01:48 PM


Related issues

Related to ISIS - Feature #21: photomet - ability to run on multiple bands Acknowledged
Related to ISIS - Feature #22: photomet - Ability to look up model curves based on Target & Wavelength Acknowledged
Related to ISIS - Bug #554: Photomet problems with Lunar Lambert Closed

History

#1 Updated by Janet Barrett about 8 years ago

Randy has outlined a general plan for improving photomet and distributed it to several high end users of the software for their input. These users include Larry, Ken H., Paul, Tom, Alfred, and Tammy. This document outlines 8 main areas of improvement for photomet including:

1) Streamline the interface

7/26: I am investigating the best way to present information to the user.

     We need to keep command line (scripting) capability

     There are some benefits to combining photomet/photemplate (easier to
     rerun program with different values, no duplication of documentation)

     Current ISIS GUI class does not allow for pull down menus or 
     appearing/disappearing text fields - this would make photomet much
     easier for someone to use because they are not exposed to parameters
     that don't apply to the models they are using.

9/22: Sharmila and I were able to get the interface streamlined in the
photomet and photemplate programs. This was done by modifying the
IsisAml class to allow for a drop down menu parameter type that will
replace the list of radio buttons that is normally used when a
parameter has several options. We were also able to get the ISIS Gui
to hide/unhide edit fields as they apply to the selection in the
drop down menu. This allowed us to only show the user those fields
that apply to the option that is chosen by the drop down menu. This
helps to keep the number of parameters to a manageable size. We tested
to make sure that the command line still works as it did before. The
photemplate and photomet programs are now fully scriptable. The pull
down menus are also being used in the phoemplocal, phoempglobal, and
shadowtau programs.

2) Add capability to do wavelength dependent corrections

9/22: We did NOT complete the multiple wavelength support in the photometry
programs for the ISIS3.3.0 release. This work will be continued into
next fiscal year.

3) Add empirical Minnaert and empirical Lunar-Lambert photometric models

7/26: I have started porting the empirical Minnaert model

9/22: Both Minnaert empirical and Lunar-Lambert empirical photometric models
now exist in ISIS3. They have been added as options to the photemplate
and photomet programs. The remaining Hapke Legendre was also ported to
ISIS3 and is available as an option in the photemplate and photomet
programs.

4) Port the following photometry helper programs from ISIS2:
a) pho_emp_global and pho_emp_local: to get coefficients for empirical

models that mimic a given Hapke (or potentially other) model
b) shadow_tau and shade_tau: to estimate optical depth from image
properties

7/26: I am gathering test data and will have Sharmila start porting the
pho_emp_local program this week.

9/22: Sharmila ported the phoemplocal, phoempglobal, and shadowtau programs
from ISIS2 to ISIS3. We did extensive testing of the phoemplocal and
phoempglobal programs to make sure we were getting consistent results
between ISIS2 and ISIS3. These 2 programs are in the system for the
ISIS3.3.0 release. The shadowtau program still needs to be tested to
make sure we are getting consistent results with ISIS2. If this can be
done this week, then there is a good possibility that this program
will make it into the ISIS3.3.0 release. Sharmila and I had to spend
quite a bit of time locating the appropriate free routines to replace
the Numerical Recipes routines that were used by the ISIS2 software.

5) Clean up the documentation

6) Create default parameter sets for different bodies

7) Add capability to propagate label information to mosaics so photometry can
be performed on them

7/26: I have discovered a program called copylabel in ISIS3 that allows you
to copy labels, groups, and blobs from one image to another. I need
to look at it in detail to see if provides the capability we need.

8) Other improvements (adding more surface models, create interactive version
of photomet, ability for user to provide a plug in for new photometric
functions, etc.)

#2 Updated by John Bechtell about 8 years ago

Per Janet:
The photometry is moving along.
I have assigned the pho_emp_local program to Sharmila to port to ISIS3. I am porting the remaining Hapke
Legendre function to ISIS3 along with the smooth versions of the Hapke Henyey and the Hapke Legendre.
I am still porting the empirical Minnaert function. I am planning on having a streamlined GUI ready for people
to review by next week.

#3 Updated by Janet Barrett over 7 years ago

I have tested the shadowtau program and made sure that it is giving the same results as the ISIS2 version. I will get the documentation updated and (if Randy has any spare time) I will have Randy review it. I still don't have anyone officially assigned to review documentation or software functionality for the photometric software. As soon as Randy looks at the documentation for shadowtau, I plan to get it checked into the isis3beta and isis3production systems. Further modifications can be made to its documentation before the release.

I will be working on the documentation for the other photometry programs (photomet, photemplate, phoempglobal) in parallel with shadowtau.

In addition, I am working on the following known problems with photomet:
1) Need to shorten mode names (at least for the photometric models) to make it easier to type them in. NOTE: I have made this Mantis post a parent of Mantis issue 554 which was posted by Jeff. He said that the LunarLambert model was no longer available in photomet. The problem is not with photomet - it still supports LunarLambert. Instead the problem is with the Gui and IsisAml classes. I have given a detailed description of the problem in Mantis issue 631 which is a child of Jeff's Mantis ticket 554. Jeff or Stuart will need to fix this problem in the Gui and IsisAml classes before this problem will be fixed. I was told not to modify either of these classes because I would break the entire ISIS system. I would prefer that Jeff or Stuart fix this problem so I am not held accountable for breaking the entire ISIS system. This fix needs to happen before the software can go into the next release (3.4.0) in January.
2) Fix Gui flashing/slowness which happens when a user holds down a number key in one of the parameter fields - I have Sharmila checking into this for me. NOTE: If this problem cannot be fixed, we need to decide if the Gui interface should be returned to its old state (use radio buttons instead of pull down menus).
3) Make photomet backwards compatible (so it works with all the old PVL files)
4) Add Hillier as a photometric model option

I am not going to get the multi-wavelength capability added to the photometry software before the next release in January. There are too many other problems to take care of and I don't want to rush adding this capability because it needs to be thought out carefully.

#4 Updated by Janet Barrett over 7 years ago

This is an update on the Gui flashing/slowness problem that Jeff reported in Mantis post 624. Sharmila was able to locate the problem. The problem existed in the Gui class prior to adding the drop down menu in the photometry software interface. Every time a character is typed in any edit field of the application GUI, then the Gui class does an enable/disable of every object in the GUI. This is what causes the slowness and flashing. This enable/disable is not necessary, so Sharmila was able to fix the code for the new photometry interface that gets rid of the slowness and flashing. This is another example of Jeff blaming Sharmila and I for code that he and Stuart wrote years ago.

#5 Updated by Stuart Sides over 7 years ago

Looks like the problem is fixed, so I set it to resolved.

#6 Updated by Stuart Sides over 7 years ago

Looks like the problem is fixed, so I set it to resolved.

#7 Updated by Laszlo Kestay over 7 years ago

I am fully satisfied that this ticket is closed.

Also available in: Atom PDF