Project

General

Profile

Bug #3923

cam2map failure on LRO NAC image

Added by Stuart Sides over 1 year ago. Updated 4 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Applications
Target version:
Impact:
Software Version:
Test Reviewer:

Description

While processing LRO NAC images, I came across a few images that gave me errors:

cam2map from=M124321480RE_cal_echo.cub map=WAC_nearside.map to=M124321480RE_cal_echo_map.cub
PROGRAMMER ERROR Angle cannot be a non-Null special pixel.

History

#1 Updated by Stuart Sides over 1 year ago

This issue was pulled out of #3917 as a separate bug. We will address it as resources become available. The images in question have been moved to the m03923_3917 data area.

#2 Updated by Tammy Becker over 1 year ago

  • Status changed from New to Acknowledged

#3 Updated by Stuart Sides 6 months ago

  • Target version set to 3.5.1 (Sprint 1)

Research and reproduce first.

#4 Updated by Jesse Mapel 6 months ago

  • Assignee set to Jesse Mapel

#5 Updated by Jesse Mapel 6 months ago

  • Status changed from Acknowledged to In Progress

#6 Updated by Jesse Mapel 6 months ago

I was unable to reproduce the bug using the following steps:

  1. Ingestion:
    lronac2isis from=M124321480RE.IMG to=M124321480RE.cub

  2. Calibration:
    lronaccal from=M124321480RE.cub to=M124321480RE_cal.cub
    lronacecho from=M124321480RE_cal.cub to=M124321480RE_cal_echo.cub

  3. Projection:
    spiceinit from=M124321480RE_cal_echo.cub
    cam2map from=M124321480RE_cal_echo.cub to=M124321480RE_cal_echo_sp.cub

There were no errors during the projection process and the output map projection looks reasonable from visual inspection.
Note that I do not have the map file used, so the mapping was done with the default Sinusoidal map

#7 Updated by Jesse Mapel 6 months ago

  • Status changed from In Progress to Resolved

#8 Updated by Jesse Mapel 6 months ago

Test data and results can be found at /work/projects/isis/latest/m03923

#9 Updated by Jesse Mapel 6 months ago

  • Status changed from Resolved to Rejected

This ticket is being rejected because we were unable to reproduce the error. If there are more details about the error or anything that we missed please comment on this ticket and it will be reopened.

#10 Updated by Stuart Sides 4 months ago

  • Target version changed from 3.5.1 (Sprint 1) to 3.5.1 (2017-08-08 Aug)

Also available in: Atom PDF