Project

General

Profile

Crash #4561

cnetref - print.prt/session logging issue

Added by Lynn Weller 12 months ago. Updated 10 months ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Applications
Impact:

The error may be causing other problems as well (see related issues). The fix to this issue is only expected to fix the problem, and not change the output of any other program.

Software Version:
Test Reviewer:

Description

  • New operating system (astrovm4), running under isis3beta2016-12-13 or /work/projects/progteam/kedmundson/ipceTest2016-11-14-KLE
  • 701 images have no problem running this program under new OS, 161 fail and all in the same way
  • All of the failure images work successfully under the old OS (on astrovm3) using isis version /work/projects/isis/latest/m03890/trunk/ (update to camera model only exists under this version and the new OS)
  • Other control network programs have no trouble with the failed images in other states of processing (all successful: cnetadd, pointreg, cnetedit, cnetstats, jigsaw)
  • Test data: /work/users/lweller/Isis3Tests/CnetRef/SessionFileProblem/

Command line with error message (seems to fail at ~36% processed after loading control points):
cnetref froml=M3G20090422T153400_V03_L1B_Add.lis cnet=M3G20090422T153400_V03_L1B_Add.net onet=M3G20090422T153400_V03_L1B_Add_Ref.net criteria=interest deffile=gradient_operator_lspace400.def log=M3G20090422T153400_V03_L1B_Add_Ref.log
cnetref: Loading Control Points...
100% Processed
cnetref: Creating Isis 3 serial numbers from list file.
cnetref: Choosing Reference by Interest...
WARNING Unable to write session log [print.prt] Disk may be full or directory permissions not writeable

A slightly different run of cnetref has more interesting output that might be useful in debugging:
cnetref froml=M3G20090422T153400_V03_L1B_Add.lis cnet=M3G20090422T153400_V03_L1B_Add.net onet=M3G20090422T153400_V03_L1B_Add_Ref.net criteria=emission log=M3G20090422T153400_V03_L1B_Add_Ref.log
cnetref: Loading Control Points...
100% Processed
cnetref: Creating Isis 3 serial numbers from list file.
cnetref: Choosing Reference by Emission...
terminate called after throwing an instance of 'Isis::IException'
what(): I/O ERROR TextFile:Open:-> Unable to open: [input]:[/work/projects/progteam/kedmundson/ipceTest2016-11-14-KLE/isis/version] in TextFile.cpp at 313.
Abort (core dumped)

No print.prt file is created in either case.

The subdirectory Astrovm3_m03890/ contains successful output. This seems like a new OS sort of problem since it runs fine on the old OS, but maybe the new OS is seeming something fishy about these data (M3) that the old one does not.


Related issues

Related to ISIS - Crash #4563: qnet - new isis version can't load Themis IR network (jigsaw has same issue) Closed
Related to ISIS - Bug #4890: jigsaw and qnet fail on LROC NAC npolar dataset Closed

History

#1 Updated by Lynn Weller 12 months ago

  • Description updated (diff)

#2 Updated by Lynn Weller 12 months ago

  • Subject changed from cnetref - print.prt issue to cnetref - print.prt/session logging issue

#4 Updated by Tammy Becker 12 months ago

  • Status changed from New to Acknowledged

#5 Updated by Lynn Weller 12 months ago

  • Related to Crash #4563: qnet - new isis version can't load Themis IR network (jigsaw has same issue) added

#6 Updated by Stuart Sides 12 months ago

  • Status changed from Acknowledged to Assigned
  • Assignee set to Stuart Sides

#7 Updated by Stuart Sides 11 months ago

  • Status changed from Assigned to Resolved
  • Impact updated (diff)

Please check other application that are having odd issues with throwing many error messages and then crashing or becoming non-responsive.

The testing area was built on for astrovm4

#8 Updated by Lynn Weller 11 months ago

  • Status changed from Resolved to Closed

Success! The changes fixed the problem and now all 161 images that had failed before run successfully through cnetref (I had a cluster job set up for this...only took a few minutes to confirm).
The change also fixed the problems documented under post #4563.

#9 Updated by Stuart Sides 11 months ago

No tests were added due to the large number of files required to reproduce the error, and the resource limit that was used up could be different on each platform.

#10 Updated by Stuart Sides 10 months ago

  • Target version set to 3.5.0 (FY17 2017-01-25 Jan)

#11 Updated by Lynn Weller 7 months ago

  • Related to Bug #4890: jigsaw and qnet fail on LROC NAC npolar dataset added

Also available in: Atom PDF