Project

General

Profile

Crash #4563

qnet - new isis version can't load Themis IR network (jigsaw has same issue)

Added by Lynn Weller 12 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Block
Assignee:
Category:
Applications
Impact:
Software Version:
Test Reviewer:

Description

Running on astrovm4 using either isis3beta2016-12-13 or Ken's version isis3beta2016-12-13
Test data under /work/users/lweller/Isis3Tests/Qnet/NaifErrors/. This is not a mini network, but it is moderate in size and there are about 3000 images, so don't bother copying them to your working directory (the images are under /work/projects/themis_control/).

Qnet will Load control points but at about 36% progress while "setting input images" an Error dialog opens with many errors having to do with trying to open an image (which exists), followed by many errors having to do with the shape file (which also exists). This problem is new (I don't think it existed a week ago), and for the test data provided it is very reproducible.

I first encountered this working with an M3 control network and get a similar error, but only after the points and images are loaded and after loading points. Not sure why this data set got further other than there are only 840 images in the network. Don't know. But this themis data make fail every time I tried.

See that attached png for the error message.

This may be related to redmine post #4561.

qnetError_ThemisIR_NAIFErrors.png View (40.7 KB) Lynn Weller, 2016-12-19 03:18 PM


Related issues

Related to ISIS - Crash #4561: cnetref - print.prt/session logging issue Closed
Related to ISIS - Bug #4890: jigsaw and qnet fail on LROC NAC npolar dataset Closed

History

#1 Updated by Lynn Weller 12 months ago

  • Related to Crash #4561: cnetref - print.prt/session logging issue added

#2 Updated by Tammy Becker 12 months ago

  • Status changed from New to Acknowledged

#3 Updated by Lynn Weller 12 months ago

  • Description updated (diff)

#4 Updated by Lynn Weller 12 months ago

The number of images in the image list seems to matter for this problem. I can't reproduce the problem with small datasets. The Themis network I provided has 2760 images. I just tried to load my LROC NAC polar network which has 3682 images (and of a larger file size than Themis IR) and qnet throws a warning at 27% of "setting input images" complaining only about not being able to initialize camera model and not being able to open an image, which definitely exists. So it will be important to use the provided data to reproduce the problem, otherwise you might not see the problem.

#5 Updated by Lynn Weller 12 months ago

  • Subject changed from qnet - new isis version can't load Themis IR network to qnet - new isis version can't load Themis IR network (jigsaw has same issue)

jigsaw is also broken in the same way - loads control points, then dies while "setting input images" with similar errors. The data in this directory have been passed to jigsaw to demonstrate - see jig_command.txt for the command and print.prt for the errors.

These errors (qnet and jigsaw) are not encountered when running small test data sets but only with my "real" daily networks that contain hundreds to many thousands of images and thousands to hundreds of thousands of points. I suspect this is why app/unit tests are at not least catching the jigsaw error - the test data sets are too small and do not represent what is more typical of some users.

Let me know if this needs to be a separate post.

#6 Updated by Lynn Weller 12 months ago

Resolved via the fixes in #4561 - qnet and jigsaw are successful.

#7 Updated by Stuart Sides 12 months ago

  • Status changed from Acknowledged to Resolved
  • Assignee set to Stuart Sides
  • Target version set to 3.5.0 (FY17 2017-01-25 Jan)

Issue was caused by the same thing as #4561 and has been resolved with it.

#8 Updated by Lynn Weller 12 months ago

  • Status changed from Resolved to Closed

#9 Updated by Lynn Weller 7 months ago

  • Related to Bug #4890: jigsaw and qnet fail on LROC NAC npolar dataset added

Also available in: Atom PDF