Project

General

Profile

Bug #4575

ISIS Applications abort when installed on non-dev Mac systems - can't find cocoa plugin

Added by Kris Becker almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Block
Category:
Infrastructure
Impact:

Applications on MacOS will be operational outside a development environment.

Software Version:
Test Reviewer:

Description

When the ISIS 3.5 release candidate system is installed on MacOSX 10.11 platforms (that do not contain the ISIS development environment), all applications abort with the following message:

This application failed to start because it could not find or load the Qt platform plugin "cocoa"
in "".

Reinstalling the application may fix this problem.
Abort

This issue must be fixed before the ISIS 3.5 release.

Related information can be found at these links:

http://stackoverflow.com/questions/36002308/qt5-5-failed-to-load-platform-plugin-cocoa-macos-10-9
https://bugreports.qt.io/browse/QTBUG-48015
http://doc.qt.io/qt-5/osx-deployment.html

Note ISIS is not built as an app bundle so some reported "solutions" for this situation may not apply.


Related issues

Related to ISIS - Bug #4856: Closed Bug #4575 - MacOSX cocoa load error Closed

History

#1 Updated by Tammy Becker almost 2 years ago

  • Status changed from New to Acknowledged

#2 Updated by Kelvin Rodriguez almost 2 years ago

  • Assignee set to Kelvin Rodriguez

#3 Updated by Kelvin Rodriguez almost 2 years ago

  • Status changed from Acknowledged to In Progress

#4 Updated by Kelvin Rodriguez almost 2 years ago

  • Status changed from In Progress to Resolved

#5 Updated by Kelvin Rodriguez almost 2 years ago

  • Impact updated (diff)

#6 Updated by Kris Becker over 1 year ago

  • Status changed from Resolved to Closed

Thanks!

#7 Updated by Tammy Becker over 1 year ago

  • Related to Bug #4856: Closed Bug #4575 - MacOSX cocoa load error added

Also available in: Atom PDF