Project

General

Profile

Question #4592

Autoseed producing empty control net claiming there's no image overlaps

Added by Sierra Ferguson 11 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Applications
Target version:
-
Test Reviewer:

Description

Hi all, I'm trying to control the mosaic that I'm making out of three Cassini ISS images for Tethys. I checked the images in qmos and they definitely do show some overlap with the other images in the list. However, when I go to run autoseed, I receive the error "USER ERROR The ouput control network is empty. This is likely due to the input cubes failing to overlap." I'm not sure what is going wrong when it's calculating the image overlaps. I've run camstats on the files as well as footprintinit, findimageoverlaps, and overlapstats. Before these steps I've run ciss2isis, spiceinit, cisscal, lowpass, and trim.

This is the autoseed command that I've been trying to run: autoseed fromlist=rootmos.lis deffile=tethyseqgrid.def overlaplist=imageoverlap.lis onet=tethyseq.net errors=cneterrors.csv networkid=Tethyseqmos pointid=Tethyseqmos_???? description="Network for the eq mosaic"

Here's the command that I've been running for findimageoverlaps: findimageoverlaps fromlist=rootmos.lis overlaplist=overlaptest1.lis this runs fine and it shows me zero errors.

I'm wondering if the autoseed error is being caused by the def file, or if it really is because there aren't any image overlaps. The attached screenshot shows what I see in qmos when I load in the image list. Is there anyway that I can fix the image overlaps so that I can continue making the control net?

Thanks,

~Sierra

This is the def file that I'm currently using: "Group = PolygonSeederAlgorithm

# Seeds the polygon with Control Points by creating a grid, the centermost grid
# is placed in the center of the polygon. Then, one Control Point is placed in the
# center of each grid where there is overlap at that center of that grid square.
# The following XSpacing/YSpacing parameters denote the dimensions of the grid.
Name = Grid

# The minimum thickness required to seed the polygon with Control Points. A
# thickness of 1.0 means that the polygon is a square. A thickness of 0.5
# means that the polygon is a 2:1 rectangle. A thickness of 0.25 means that
# the polygon is a 4:1 rectangle, and so forth.
# Any polygon with a thickness less than MinimumThickness will not be seeded.
MinimumThickness = 0.3

# The minimum area (in square meters) required to seed the polygon with
# Control Points. Any polygon with an area less than MinimumArea will not be
# seeded.
MinimumArea = 10

# The spacing in meters between Control Points in the X direction. One
# Control Point will be placed every XSpacing meters in the X direction.
# This combined with the YSpacing, will create a grid of Control Points
# across the polygon.
XSpacing = 1500

# The spacing in meters between Control Points in the Y direction. One
# Control Point will be placed every YSpacing meters in the Y direction.
# This combined with the XSpacing, will create a grid of Control Points
# across the polygon.
YSpacing = 1500

End_Group"

Screen Shot 2017-01-26 at 6.34.14 PM.png View - Image showing the overlaps that I see in Qmos (24.2 KB) Sierra Ferguson, 2017-01-26 06:34 PM

N1713137226_1_tr.cub - File for the mosaic (4.1 MB) Sierra Ferguson, 2017-01-26 06:37 PM

N1713137436_1_tr.cub - File for the mosaic (4.1 MB) Sierra Ferguson, 2017-01-26 06:37 PM

N1713137645_1_tr.cub - File for the mosaic (4.1 MB) Sierra Ferguson, 2017-01-26 06:37 PM


Related issues

Related to ISIS - Question #4665: Latitude wrong after a jigsaw run Closed

History

#1 Updated by Tammy Becker 11 months ago

  • Status changed from New to Acknowledged

#2 Updated by Lynn Weller 11 months ago

  • Assignee set to Lynn Weller

Hi Sierra,

There are a couple of things that may be going on here. For starters, let's make sure your work flow for building a network is in the right order.

After your initial processing steps (ciss2isis, spiceinit, cisscal, lowpass, and trim), in order to use autoseed properly you should do the following:
- run footprintinit and visually verify footprints/overlaps in qmos (looks like you have this one covered)
- run findimageoverlaps (not a verbose program unless you set errors=true and it actually encounters errors to report) - the overlaplist output file is necessary for the following steps
- optionally run overlapstats to get some basic statistics about your overlaps (output overlaplist from findimageoverlaps)
- run autoseed being sure to use the output overlaplist from findimageoverlaps as input

Autoseed does not calculate overlaps, it uses the overlaps calculated from findimageoverlaps. Be certain the input to autoseed is the output from findimageoverlaps. I mention this because the commands in your post show the findimageoverlaps overlaplist=overlaptest1.lis and the input to autoseed overlaplist=imageoverlap.lis which are not the same file. Maybe just a typo here?

If you managed to execute all of the above properly, then the most likely issue is the autoseed deffile. It looks as though you are simply using the ISIS grid.def template as input. This file is a template and the values for the keywords it contains will need to be modified for your specific data set. This will likely take some experimentation as it may take a bit to get comfortable with what the parameters mean. Some of the values in the output from overlapstats may help here (polygon thickness), but I find it easier to try a couple of runs of autoseed and look at the output via qmos to see what is and isn't working.

The overlaps are very skinny, so for starters I would set MinimumThickness=0.0 and MinimumArea=0.0 in your deffile. The values you choose for XSpacing and YSpacing will likely take a few tries. Keep in mind the values are in meters. You will need to consider how many meters there are in your overlapping areas and in your case the skinniest overlap will drive this number. I'm sorry I'm not familiar enough with Cassini to make a recommendation.

You can get sense of what is going on by loading your images and output network into qmos. The points can be loaded by clicking on the Control Net icon (blue with a white diamond in it) and selecting your network. If you feel you have too many or not enough points, modify your X/YSpacing in the autoseed deffile in the appropriate direction and try again.

If you are not already familiar, here are some links to training guides that might be of use to you:

Autoseed: https://fixit.wr.usgs.gov/fixit/projects/isis/wiki/Autoseed
Qmos: https://fixit.wr.usgs.gov/fixit/attachments/download/976/Qmos.pdf

These can be found under the ISIS support forum wiki here: https://isis.astrogeology.usgs.gov/fixit/projects/isis/wiki/ISIS_Online_Workshops

It appears training documents are not yet available for ISIS Control Workshop 2014 (under the Hands-On Workshops links) which would possibly provide you with more guidance after autoseed. We'll try and let you know when that link goes live if it happens in the near future.

Please let us know if you are able to get autoseed running for your data with some tweaks to the deffile.

Lynn

#3 Updated by Sierra Ferguson 11 months ago

Hi Lynn,

I changed the deffile and I was able to generate the control net. Thank you for the help!

~Sierra

Lynn Weller wrote:

Hi Sierra,

There are a couple of things that may be going on here. For starters, let's make sure your work flow for building a network is in the right order.

After your initial processing steps (ciss2isis, spiceinit, cisscal, lowpass, and trim), in order to use autoseed properly you should do the following:
- run footprintinit and visually verify footprints/overlaps in qmos (looks like you have this one covered)
- run findimageoverlaps (not a verbose program unless you set errors=true and it actually encounters errors to report) - the overlaplist output file is necessary for the following steps
- optionally run overlapstats to get some basic statistics about your overlaps (output overlaplist from findimageoverlaps)
- run autoseed being sure to use the output overlaplist from findimageoverlaps as input

Autoseed does not calculate overlaps, it uses the overlaps calculated from findimageoverlaps. Be certain the input to autoseed is the output from findimageoverlaps. I mention this because the commands in your post show the findimageoverlaps overlaplist=overlaptest1.lis and the input to autoseed overlaplist=imageoverlap.lis which are not the same file. Maybe just a typo here?

If you managed to execute all of the above properly, then the most likely issue is the autoseed deffile. It looks as though you are simply using the ISIS grid.def template as input. This file is a template and the values for the keywords it contains will need to be modified for your specific data set. This will likely take some experimentation as it may take a bit to get comfortable with what the parameters mean. Some of the values in the output from overlapstats may help here (polygon thickness), but I find it easier to try a couple of runs of autoseed and look at the output via qmos to see what is and isn't working.

The overlaps are very skinny, so for starters I would set MinimumThickness=0.0 and MinimumArea=0.0 in your deffile. The values you choose for XSpacing and YSpacing will likely take a few tries. Keep in mind the values are in meters. You will need to consider how many meters there are in your overlapping areas and in your case the skinniest overlap will drive this number. I'm sorry I'm not familiar enough with Cassini to make a recommendation.

You can get sense of what is going on by loading your images and output network into qmos. The points can be loaded by clicking on the Control Net icon (blue with a white diamond in it) and selecting your network. If you feel you have too many or not enough points, modify your X/YSpacing in the autoseed deffile in the appropriate direction and try again.

If you are not already familiar, here are some links to training guides that might be of use to you:

Autoseed: https://fixit.wr.usgs.gov/fixit/projects/isis/wiki/Autoseed
Qmos: https://fixit.wr.usgs.gov/fixit/attachments/download/976/Qmos.pdf

These can be found under the ISIS support forum wiki here: https://isis.astrogeology.usgs.gov/fixit/projects/isis/wiki/ISIS_Online_Workshops

It appears training documents are not yet available for ISIS Control Workshop 2014 (under the Hands-On Workshops links) which would possibly provide you with more guidance after autoseed. We'll try and let you know when that link goes live if it happens in the near future.

Please let us know if you are able to get autoseed running for your data with some tweaks to the deffile.

Lynn

#6 Updated by Tammy Becker 11 months ago

  • Status changed from Acknowledged to Resolved

#7 Updated by Tammy Becker 8 months ago

#8 Updated by Lynn Weller 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF