Project

General

Profile

Bug #4601

Interactive programs display "Q" errors in launching shells

Added by Lynn Weller over 1 year ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Applications
Target version:
Impact:
Software Version:
Test Reviewer:

Description

When interactive programs are launched (qview, qnet, qmos and cneteditor have been tested), the following is displayed in the launching:

failed to get the current screen resources
QXcbConnection: XCB error: 170 (Unknown), sequence: 168, resource id: 90, major code: 146 (Unknown), minor code: 20

In addition, when a network is loaded in cneteditor, the following is displayed in addition to the above:

QObject::startTimer: Timers cannot be started from another thread
QObject::killTimer: Timers cannot be stopped from another thread
QObject::startTimer: Timers cannot be started from another thread
QObject::killTimer: Timers cannot be stopped from another thread

No data necessary to reproduce qview, qmos or qnet messages, just launch them. If you need a network to reproduce cneteditor, load any network found in the subdirectories of /work/projects/usertests/UserTestPlans/Apps/qnet/.
I'm running isis3production2017-01-17.
This occurs via putty/Xming as well as my virtual environment running on astrovm4.

History

#1 Updated by Tammy Becker over 1 year ago

  • Status changed from New to Acknowledged

#2 Updated by Stuart Sides over 1 year ago

  • Target version set to 3.5.0 (FY17-patch 2017-04-07 Apr)

#3 Updated by Ian Humphrey over 1 year ago

Not fully working on this right now, just spending a couple minutes looking into it. I didn't reproduce the QXcbConnection error, but I found a little information regarding the error code.

A QTBUG report showed a useful xdpyinfo command to find the major opcode error reported (146). See QTBUG-31389

I skimmed the report and found the following command that I ran:

> xdpyinfo -queryExtensions | grep 146
DPMS (opcode: 146)

DPMS represents the Display Power Management Signaling Protocol in X11, more details here.

Not sure how helpful or unhelpful this may be, but just in case I've provided it for whoever picks up this ticket.

#4 Updated by Ian Humphrey over 1 year ago

  • Status changed from Acknowledged to Assigned
  • Assignee set to Ian Humphrey

#5 Updated by Ian Humphrey over 1 year ago

  • Status changed from Assigned to In Progress

#6 Updated by Ian Humphrey over 1 year ago

  • Status changed from In Progress to Acknowledged

I think that this might be occurring within AbstractTableModel::sort(). Un-assigning for now in case someone else might want to pick it up, I'll resume on Friday if not.

#7 Updated by Tammy Becker over 1 year ago

Just want to 'ditto' on this issue.

I'm encountering the same errors as described with cneteditor on astrovm4 (isis3.5.0).

Thankfully cneteditor seems to function as expected.

Thanks,

#8 Updated by Tammy Becker over 1 year ago

  • Target version changed from 3.5.0 (FY17-patch 2017-04-07 Apr) to 3.5.1 (Sprint 1)

#10 Updated by Ian Humphrey over 1 year ago

  • Assignee deleted (Ian Humphrey)

#11 Updated by Cole Neubauer over 1 year ago

  • Assignee set to Cole Neubauer

#12 Updated by Cole Neubauer over 1 year ago

  • Status changed from Acknowledged to In Progress

#13 Updated by Cole Neubauer over 1 year ago

  • Status changed from In Progress to Acknowledged
  • Assignee deleted (Cole Neubauer)

Taking myself off this for now. The error messages seem to be caused by a Qt bug not seeing a virtual screen as a real screen. The bug is outlined here https://bugreports.qt.io/browse/QTBUG-31389?page=com.atlassian.jira.plugin.system.issuetabpanels%3Aall-tabpanel
They acknowledge it doesn't change functionality. On their bug tracker they list it as fixed for version 5.5.0 Beta. The plan currently is to wait for the Qt version we use to upgrade to 5.7, as we will be upgrading relatively shortly, and revisit this ticket to see if the error messages are still there.

#14 Updated by Tyler Wilson over 1 year ago

  • Assignee set to Tyler Wilson

#15 Updated by Tyler Wilson over 1 year ago

  • Status changed from Acknowledged to In Progress

#16 Updated by Tyler Wilson over 1 year ago

  • Status changed from In Progress to Acknowledged
  • Assignee deleted (Tyler Wilson)

#17 Updated by Stuart Sides over 1 year ago

  • Status changed from Acknowledged to Blocked

Blocked until we see if a new version of QT will fix the problem

#18 Updated by Stuart Sides about 1 year ago

  • Target version changed from 3.5.1 (Sprint 1) to 3.5.2 (2017-01-31 Jan)

#19 Updated by Makayla Shepherd about 1 year ago

We're going to leave this in blocked until we get Fedora 25 up to see if the new version of QT fixes it.

#20 Updated by Stuart Sides 10 months ago

  • Status changed from Blocked to Acknowledged

FC25 is ready

#21 Updated by Cole Neubauer 9 months ago

  • Assignee set to Cole Neubauer

#22 Updated by Cole Neubauer 9 months ago

  • Status changed from Acknowledged to In Progress

#23 Updated by Cole Neubauer 9 months ago

This was an issue that was "fixed" above in qt 5.5 beta however someone else reported the same issue in https://bugreports.qt.io/browse/QTBUG-48453 on version 5.5 and they determined at that point it is not qt's issue because doing a clean install of the latest(at the time) versions of Xming and Putty(0.60). I am waiting to hear back from IT on the current versions on user boxes and on the windows remotes.

#24 Updated by Lynn Weller 9 months ago

  • Status changed from In Progress to Feedback

My work is done primarily on a virtual machine using VmWare and shells to astrovm4.
I also use putty/xming on occasion and see it there as well. My current version of putty is 0.67 and Xming is 6.9.0.31.

#25 Updated by Cole Neubauer 9 months ago

  • Status changed from Feedback to In Progress

#26 Updated by Cole Neubauer 9 months ago

From my testing I am confident that the issue is resolved by a clean install of the ssh and xserver tools. Stuart will put in a request to IT for all the Windows machines in the building to be updated to the newer versions and to have clean installs.

#27 Updated by Makayla Shepherd 9 months ago

  • Status changed from In Progress to Resolved

#28 Updated by Lynn Weller 9 months ago

  • Status changed from Resolved to Feedback

I was just upgraded to windows 10 and received a new install of putty and xming, but continue to get these errors in my launching shell when using qview:

failed to get the current screen resources
QXcbConnection: XCB error: 170 (Unknown), sequence: 170, resource id: 90, major code: 146 (Unknown), minor code: 20

and cneteditor:

failed to get the current screen resources
QXcbConnection: XCB error: 170 (Unknown), sequence: 170, resource id: 90, major code: 146 (Unknown), minor code: 20
QObject::startTimer: Timers cannot be started from another thread
QObject::startTimer: Timers cannot be started from another thread
QObject::killTimer: Timers cannot be stopped from another thread
QObject::killTimer: Timers cannot be stopped from another thread

Is there something else that should have gotten a fresh install? Evin did the upgrades.

#29 Updated by Lynn Weller 9 months ago

  • Status changed from Feedback to Closed

Apparently that clean install wasn't really clean.
Got it done the right way and the XCB error message is gone.
cneteditor still has its timer complaints, but that is a known issue covered by another post (?).

Also available in: Atom PDF