Project

General

Profile

Question #4652

isis3 applications do not start on Virtual Box Ubuntu 14.04

Added by Valentin Valentin 9 months ago. Updated 8 months ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Installation
Target version:
-
Software Version:
Test Reviewer:

Description

Dear ISIS Team,

I would like to use ISIS3 for my thesis, but I have problems with the startup. There are several closed tickets in this forum which describe the same issue, but unfortunately their solutions do not work in my case and I spent the last days trying many different approaches to solve the issue on my own, but without success.
I am using a virtual machine with Ubuntu 14.04 (Bourne shell) on a Windows 10 host (ISIS Version is 3.5.0.7383) and I strictly followed the guidelines from: https: //isis.astrogeology.usgs.gov/ documents/ InstallGuide/ index.html# ApolloMission, which were the following steps:

$ cd /Desktop
$ mkdir isis3
$ cd isis3
rsync -azv --delete --partial isisdist.astrogeology.usgs.gov::x86-64_linux_UBUNTU/isis .
rsync -azv --delete --partial isisdist.astrogeology.usgs.gov::isis3data/data/base data/
rsync -azv --delete --partial isisdist.astrogeology.usgs.gov::isis3data/data/mro data/
ISISROOT=/work1/isis3/isis
export ISISROOT
. $ISISROOT/scripts/isis3Startup.sh

When I run the startup file the terminal accepts the command and when I use:
echo $ISISROOT
it gives me the correct path to the folder isis which is
/home/valentin/Desktop/isis3/isis

But when I try to use for example qview or lowpass he answers me:
Lowpass: error while loading shared libraries: libblas.so.3: cannot open shared object file: no such file or directory
However, the file actually is in the folder ~/isis3/isis/3rdParty/lib with a file size of 30 Bytes.

When I try:
ls $ISISROOT
He gives me: 3rdParty bin config doc inc IsisDlm IsisPreferences lib license.txt make Makefile scripts src templates version.

When I try:
ls $ISIS3DATA
he tells me that access to /usgs/cpkgs/isis3/data is not possible, folder not found.

When I try:
ls -I $ISISROOT/bin/lowpass
he returns a greenish style line which says /home/valentin/Schreibtisch/isis3/isis/bin/lowpass.

The structure of my isis3 folder is as follows:
Isis3 = main folder on desktop (153.5 GB), contains two folders, data (151.7 GB) and isis (1.9 GB). Data contains base (6.6 GB) and mro (145.1 GB), isis contains 3rdParty, bin, config, doc, inc, IsisDlm, lib, make, scripts, src, templates and four files IsisPreferences, license.txt, Makefile, version.

Thank you very much for your help!!
Best regards, Valentin

History

#1 Updated by Tammy Becker 9 months ago

  • Status changed from New to Acknowledged

#3 Updated by Ian Humphrey 9 months ago

  • Status changed from Acknowledged to In Progress
  • Assignee set to Ian Humphrey

#4 Updated by Ian Humphrey 9 months ago

  • Status changed from In Progress to Resolved

Hi Valentin,

It looks like the blas library was not being distributed with our latest Ubuntu public release.

I've put the library and correct links into the latest Ubuntu (14.04) public release of ISIS (3.5.0).

If you go to the directory where you installed ISIS, you can re-run this rsync command to get this change:

$ cd /Desktop/isis3/isis/3rdParty/lib
rsync -azv --delete --partial isisdist.astrogeology.usgs.gov::x86-64_linux_UBUNTU/isis/3rdParty/lib/ .

Let me know if this works.

-Ian

#5 Updated by Valentin Valentin 9 months ago

Hey Ian,

that worked perfectly well! Thank you very much for your help!

Best regards, Valentin

#6 Updated by Tammy Becker 8 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF