Project

General

Profile

Question #4665

Latitude wrong after a jigsaw run

Added by Sierra Ferguson over 1 year ago. Updated 12 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Tammy Becker
Category:
Applications
Target version:
-
Test Reviewer:

Description

I had posted about an issue I was having using autoseed a while back and that was resolved successfully. I had created the mosaic that I was wanting with no other problems. Until I imported the mosaic into ArcMap. I noticed that the controlled mosaic was offset by at least 3 degrees of latitude. My original mosaic (without controlling it at all) had the correct location that the IAU also lists for that named crater. I then proceeded to try and figure out how to resolve this offset within isis and I came across the deltack routine. I applied that successfully and things now had the correct locations! However, when I went to go and mosaic it, the seams on the end product looked atrocious.

I’ve tracked where the latitude change happens in my processing steps. It appears to happen after I run the jigsaw routine with the nice control net. I’ve checked the net inside Qnet and the latitudes all look fine in there and the points are still referenced between the images just fine. It’s after the jigsaw with the control net that the latitude goes wrong.

I currently run these steps in this order: ciss2isis, spiceinit, cisscal (with new file name including _cal.cub), lowpass (now another file is created with the same name but with _fill.cub at the end), then I use trim which comes out with a file name of typically _tr.cub. I then run camstats and footprintinit.

What I tried next is created a new file starting with my trim step (in this case trr.cub and _trrrr.cub). I re-run camstats and footprintinit and use those files to run deltack. I updated the pointing and it all looked fine. I then used that list in findimageoverlaps and autoseed. I re-controlled that mosaic with the new net that I made and I ran into an error with jigsaw. I got the error of `USER ERROR Unable to bundle adjust network [tethyshopefulfinalnet.net].
USER ERROR Unable to map apriori surface point for measure Cassini-Huygens/ISSNA/1/1713137436.100 on point tethyy
0037 into focal plane.”**` I don’t get this error with the other control net, so I suspect that it might just be a problem with this net.

To test if it was the control net or the images having used deltack I went back to the old control net that worked in the past. Jigsaw ran successfully, but the deltack info was removed and the latitude was back to being incorrect. My current takeaway is that I can’t use both deltack and qnet to fix the pointing on the image since it appears that jigsaw overwrote the deltack on the image and replaced it with values from the jigsaw of the control net. My question then is this, is there a way within isis to update that latitude and keep the control net looking as nice as it does now? There is a georefferencing tool within ArcGIS that can be used, but the file must be converted to a tiff and I’m not 100% sure what information I lose when I make that conversion.

I’ve attached the _fill files that I use to check for the correct latitudes that I want to update using deltack. It wouldn't let me upload my .net files and I'm not sure how else to upload it, but I can get it up immediately if needed.

The large crater in N1713137226_1 should have the coordinates of 2.32N 184.71 +W (0-360 ,) However, in the _trr.cub files the crater is at -2.32N. Other features in the following 2 images are also offset by some amount like the first crater.

My rootlist is as follows:
N1713137226_1_trr.cub
N1713137645_1_trr.cub
N1713137436_1_trr.cub

Thank you for your help,

~Sierra

N1713137436_1_trr.cub (4.12 MB) Sierra Ferguson, 2017-03-15 11:46 AM

N1713137226_1_trr.cub (4.12 MB) Sierra Ferguson, 2017-03-15 11:47 AM

N1713137645_1_trr.cub (4.12 MB) Sierra Ferguson, 2017-03-15 11:47 AM

N1713137226_1_fill.cub (4.1 MB) Sierra Ferguson, 2017-03-15 11:47 AM

N1713137436_1_fill.cub (4.1 MB) Sierra Ferguson, 2017-03-15 11:47 AM

N1713137645_1_fill.cub (4.1 MB) Sierra Ferguson, 2017-03-15 11:47 AM


Related issues

Related to ISIS - Question #4592: Autoseed producing empty control net claiming there's no image overlaps Closed

History

#1 Updated by Tammy Becker over 1 year ago

  • Status changed from New to Acknowledged

#2 Updated by Tammy Becker over 1 year ago

Hi Sierra,

Can you please share the following:

1) your jigsaw command
2) your input control network
3) all the output jigsaw files (jig_bundleout.txt, jig_bundleout_points.csv, jig_bundleout_images.csv and jig_residuals.csv)
4) your deltack commands
5) the source of the lat/lon location for the large crater

We need to evaluate the control network (I know Lynn helped you through this with your previous post) to determine why jigsaw adjusts the pointing of the input images so far from where they start. The cause could be the input control network and/or jigsaw needs constraints (sigmas). We will fully explain our findings to you.

Thank you,

#3 Updated by Sierra Ferguson over 1 year ago

Hi Tammy,
My apologies for seeing this so late! I didn't see an email notification from it.
1) Jigsaw command is jigsaw fromlist=rootmos.lis cnet=tethyseqfinalfinal_pleaseletthiswork.net errorpropagation=yes

2/3)So the requested files are in this dropbox https://www.dropbox.com/sh/80rnmmos5bxo8an/AACPVv0E0OfxdYwJ7pJ-lDOpa?dl=0
I'm not sure if this is the right way to send you these files since the reply isn't letting me upload .csv or .net files.

4) Deltack command: deltack from=N1713137226_1_trr.cub samp1=286 line1=514 lat1=2.08636 lon1=175.27
I've run the deltack after the jigsaw to re-update the pointing to the more accurate coordinates, but then the jigsaw switches it again.

5)The source for the crater coordinate is here: https://planetarynames.wr.usgs.gov/Feature/14429;jsessionid=3306FA4816B68B26B39844261C8176A8

~Sierra

Tammy Becker wrote:

Hi Sierra,

Can you please share the following:

1) your jigsaw command
2) your input control network
3) all the output jigsaw files (jig_bundleout.txt, jig_bundleout_points.csv, jig_bundleout_images.csv and jig_residuals.csv)
4) your deltack commands
5) the source of the lat/lon location for the large crater

We need to evaluate the control network (I know Lynn helped you through this with your previous post) to determine why jigsaw adjusts the pointing of the input images so far from where they start. The cause could be the input control network and/or jigsaw needs constraints (sigmas). We will fully explain our findings to you.

Thank you,

#4 Updated by Tammy Becker over 1 year ago

Thank you for the additional information! I just now discovered your recent message. I will report the notification issue because I didn't receive one either.

We will look into your network, etc. and get back with you!

#5 Updated by Tammy Becker about 1 year ago

I've gone through your jigsaw results and network. Email tbecker@usgs.gov and I will send you a word document that covers the details and a modified network.

In summary, you do not need to apply deltack. You can establish a 'ground' point within the control network (point type=fixed) and assign a point id and image coordinate to the desired latitude and longitude for the jigsaw bundle adjustment.

I also modified your control network, there were two points with inaccurate measurements, I "ignored" one and corrected the 2nd in qnet. I also added a "ground" point (the part that replaces the need for deltack).

#6 Updated by Tammy Becker about 1 year ago

  • Status changed from Acknowledged to In Progress
  • Assignee set to Tammy Becker

#7 Updated by Tammy Becker about 1 year ago

  • Related to Question #4592: Autoseed producing empty control net claiming there's no image overlaps added

#8 Updated by Tammy Becker 12 months ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF