Project

General

Profile

Bug #4766

Latitude error in grid

Added by Kris Becker 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Applications
Target version:
Impact:

No impact on existing functionality

Software Version:
Test Reviewer:

Description

There are some strange errors with the last version of ISIS. When I try to add a grid to a global equirectangular map or map centered on the North pole (orthographic or stereographic) I get this error:
PROGRAMMER ERROR Latitudes past 90 degrees are not valid. The latitude [90.001006] is not allowed.

But I do not get the error when doing a map centered on the South pole…

Typically I use the command lines:
ls mosaic*equi.cub | parallel grid from='{}' to='{.}'grid.cub outline=yes boundary=yes baselat=-90 baselon=0 latinc=30 loninc=30 minlat=-90 maxlat=90 minlon=0 maxlon=360 linewidth=13
ls mosaic*North.cub | parallel grid from=‘{}' to='{.}'
grid.cub boundary=yes baselat=0 baselon=0 latinc=30 loninc=30 minlat=0 maxlat=90 minlon=0 maxlon=360 linewidth=13

Never had this issue with previous versions of ISIS3.

History

#1 Updated by Jesse Mapel 8 months ago

  • Assignee set to Jesse Mapel

#2 Updated by Jesse Mapel 8 months ago

  • Status changed from New to In Progress

#3 Updated by Jesse Mapel 8 months ago

  • Impact updated (diff)

Available for testing at

/work/projects/isis/latest/m04766/

The checkout is built for Fedora 21. If a different version is needed please comment.

#4 Updated by Jesse Mapel 8 months ago

  • Status changed from In Progress to Resolved

#5 Updated by Lynn Weller 8 months ago

Could this be built for astrovm4 - I'd like to test the changes.

Just as a note, I was able to reproduce the error on one of my polar mosaics (north) and found when I allow the ground grid limits (lat/lon range) to default, the program works fine but when I set the values to include maxlat=90 I get the same error as Kris. Also as Kris indicated, the south pole does not present the same problem.

#6 Updated by Jesse Mapel 8 months ago

Now rebuilt for astrovm4.

It makes sense that it would only error on the North pole or maxlat=90. The error is caused by using a Latitude object in a for loop. If the maximum latitude in the map is 90, the Latitude object will get incremented past 90, throwing the error. For the South pole the Latitude starts at -90 and then increases, same if minlat=-90.

#7 Updated by Lynn Weller 8 months ago

Thanks for the rebuild. No more error. I only tested on polar stereographic north and south pole mosaics letting ground grid limits default then again setting the lat/lon values (including maxlat=90). Looks good.

#8 Updated by Kris Becker 8 months ago

  • Status changed from Resolved to Closed

Thanks to all.

#9 Updated by Stuart Sides 8 months ago

  • Target version changed from 3.5.1 (Sprint 1) to 3.5.1 (2017-08-08 Aug)

Also available in: Atom PDF