Question #4851

I/O error on Cassini RADAR data

Added by Shannon Shannon 11 months ago. Updated 5 months ago.

Target version:
Test Reviewer:



I'm trying to ingest a Cassini RADAR BIDR file that contains the incidence angles for a certain observation. I've downloaded the .IMG and .LBL files from the PDS but I cannot run pds2isis on them. My commands are indicated by > and the respective error messages are included directly below. (The relevant data files can be found at )

pds2isis from=BIEQH00S067_D161_T041S06_V02 to=T41_HiSAR_inc.cub
USER ERROR This image does not contain a pds label. You will need an image with a PDS label or a detached PDS label for this image.
I/O ERROR Unable to open [BIEQH00S067_D161_T041S06_V02].

pds2isis from=BIEQH00S067_D161_T041S06_V02.IMG to=T41_HiSAR_inc.cub
I/O ERROR Unknown label type in [BIEQH00S067_D161_T041S06_V02.IMG].

pds2isis from=BIEQH00S067_D161_T041S06_V02.LBL to=T41_HiSAR_inc.cub
I/O ERROR Unsupported encoding type in [BIEQH00S067_D161_T041S06_V02.LBL].

Is there some other ISIS feature that I should be using to look at these kinds of non-imagery files from Cassini RADAR?



#1 Updated by Lynn Weller 11 months ago

You'll need to download BIEQH00S067_D161_T041S06_V02.LBL and BIEQH00S067_D161_T041S06_V02.ZIP from the PDS location you provided. Extract the data from BIEQH00S067_D161_T041S06_V02.ZIP (I did this on the windows side). You will then have the associated image data ( BIEQH00S067_D161_T041S06_V02.IMG).

Then execute
pds2isis from=BIEQH00S067_D161_T041S06_V02.IMG to=BIEQH00S067_D161_T041S06_V02.cub

You should be able to view the resulting cube file via qview.

#2 Updated by Lynn Weller 11 months ago

In reviewing your original post, I see now that you tried a variety of things (including my solution), but with no success. I am unable to reproduce your errors testing on a Scientific Linux system (CentOS7) or a MacOS (prog17 for local developers information). Could you please share with us the specifics of your operating system and confirm the version of isis is the latest isis3.5.0? Thank you!

#3 Updated by Shannon Shannon 11 months ago

Hi Lynn,

According to the version file in my isis3/isis/ directory, I am running isis3.5.0:
2017-01-25 # Version date
v006 # 3rd party libraries version
stable # release stage (alpha, beta, stable)

with macOS Sierra (10.12.13).

Thanks very much for your help!

#4 Updated by Shannon Shannon 10 months ago

Here's the error info from the print.ptr info:

Object = pds2isis
IsisVersion = " stable | 2017-01-25"
ProgramVersion = 2012-11-21
ProgramPath = /Users/smack/isis/isis3/isis/bin
ExecutionDateTime = 2017-05-09T15:26:17
HostName = lumos.local
UserName = smack
Description = "Import PDS or ISIS2 image into ISIS3 cube format"

Group = UserParameters
FROM = BIEQH00S067_D161_T041S06_V02.IMG
TO = BIEQH00S067_D161_T041S06_V02.cub

Group = Error
Program = pds2isis
Class = "I/O ERROR"
Code = 4
Message = "Unknown label type in [BIEQH00S067_D161_T041S06_V02.IMG]"
File = ProcessImportPds.cpp
Line = 302

#5 Updated by Lynn Weller 10 months ago

Hi Shannon,

Thanks for providing the additional information.
I was able to get set up on a MacOS that matches your version, but I was not able to reproduce the problem with the particular file you pointed us to - the data ingest successfully. Have you had any success with any other images from the that data set? Could you humor us and download the data again, unzip the img and try again?

If you have access to tuiview or qgis you might try opening your file there. If you do take this course, please let us know how it goes.


#6 Updated by Shannon Shannon 10 months ago

Hi Lynn,

Well, I've been re-downloading, unzipping, and trying again for the last few days. But I just tried downloading into a different directory and operating isis from there--wouldn't you know that that worked? I have successfully run isis3 in this old directory before so I'm not sure where the problem came from.

For future reference, does the error message in the print.ptr file above tell you anything? I.e. Should I ever worry about tinkering with the underlying cpp files?

Thanks very much for your help, Lynn!

P.S. For kicks, I did try opening the img file directly into qgis, but the file format was unsupported.

#7 Updated by Lynn Weller 10 months ago

I'm glad you got it to work Shannon!

Unfortunately I did not find the error message useful in trying to debug the problem. I guess it's just the generic "something is wrong and I can't make this work" sort of message. The information in the print.prt did allow me to confirm we were using identical versions of isis and the program.

I typically leave the tinkering of isis code to the isis developers. Of course if you ever do end up looking into coding details and find errors we would appreciate hearing so that they can be addressed and distributed to the larger community as a whole can have access to any updates.

One last note, I was able to directly open the .img in QGIS 2.8.2, running on a windows box. I'm not familiar enough with the package to know if there is any variation in supported file type across OS's.

I'm going to request this post be resolved (it doesn't appear I have the power to do so), but if you have any additional questions you can reopen it by simply adding a note and changing status to feedback so that it gets our attention.

#8 Updated by Tammy Becker 10 months ago

  • Category set to Applications
  • Status changed from New to Acknowledged

#9 Updated by Tammy Becker 10 months ago

  • Assignee set to Lynn Weller

#10 Updated by Lynn Weller 10 months ago

  • Status changed from Acknowledged to In Progress

#11 Updated by Lynn Weller 10 months ago

  • Status changed from In Progress to Resolved

#12 Updated by Stuart Sides 5 months ago

  • Status changed from Resolved to Closed
  • Target version set to N/A

Closed for author.

Also available in: Atom PDF