Project

General

Profile

Bug #4856

Closed Bug #4575 - MacOSX cocoa load error

Added by Emily Martin about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Kris Becker
Category:
Infrastructure
Target version:
Impact:
Software Version:
Test Reviewer:

Description

I am experiencing the error message described and discussed in the Issue titled Closed Bug #4575 that refers to an error with the "cocoa" plugin. The issue is labeled as closed, but the related information listed doesn't provide a solution. I had a working version of ISIS on my MacBookPro running 10.9 and updated it early this year. Since the update I can't launch view without the 'cocoa' error. Is there a patch for this issue? Should I just try and update my existing ISIS to the latest version?

Thanks,
Emily


Related issues

Related to ISIS - Bug #4575: ISIS Applications abort when installed on non-dev Mac systems - can't find cocoa plugin Closed

History

#1 Updated by Tammy Becker about 1 year ago

  • Status changed from New to Acknowledged

#2 Updated by Tammy Becker about 1 year ago

  • Related to Bug #4575: ISIS Applications abort when installed on non-dev Mac systems - can't find cocoa plugin added

#3 Updated by Kris Becker about 1 year ago

  • Subject changed from Closed Bug #4575 to Closed Bug #4575 - MacOSX cocoa load error
  • Status changed from Acknowledged to Feedback
  • Assignee set to Kris Becker

Hi Emily...

Yes, you should update to at least ISIS 3.5.0. The fix involved adding code to initialize (QT_PLUGIN_PATH to) the Qt plugin directory containing the Mac Cocoa plugins. Be sure to update the data area as well.

If you upgraded to a newer version of MacOSX (ISIS 3.5.0 only supports 10.11 and higher), then older versions of ISIS will not run because they do not contain this fix.

Let me know how it goes...

#5 Updated by Emily Martin about 1 year ago

I've since been able to update my operating system to 10.12 and re-installed ISIS 3.5.0 and this issue has resolved itself. Thanks for the help.

#6 Updated by Kris Becker about 1 year ago

  • Status changed from Feedback to Closed
  • Target version set to N/A

Also available in: Atom PDF