Project

General

Profile

Question #4871

ISIS preference not found

Added by Saket Saket 11 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Installation
Target version:
Software Version:
Test Reviewer:

Description

I installed ISIS3 and setup the environment in bash shell. Now when i execute the command 'qview' I get the following return :

terminate called after throwing an instance of 'Isis::IException'
what(): USER ERROR The preference file $ISISROOT/IsisPreferences was not found or does not exist in Preference.cpp at 55.
Aborted (core dumped)

I can read the configuration file at $ISISROOT/IsisPreferences , So I am not sure which file or setting is missing.

History

#1 Updated by Tammy Becker 11 months ago

  • Status changed from New to Acknowledged

#3 Updated by Stuart Sides 11 months ago

  • Status changed from Acknowledged to In Progress
  • Assignee set to Stuart Sides
  • Target version set to N/A

Saket,
Please post the exact results of the following commands:
ls -l $ISISROOT
head $ISISROOT/IsisPreferences

#4 Updated by Saket Saket 11 months ago

Hi Stuart,

Here are the command returns

>ls -l $ISISROOT
total 120
drwxr-sr-x  4 saket saket  4096 Jan 25 03:05 3rdParty
drwxr-sr-x  3 saket saket 12288 Jan 25 03:36 bin
drwxr-sr-x  2 saket saket  4096 Jan 25 03:03 config
drwxr-sr-x 14 saket saket  4096 Jan 26 04:50 doc
drwxr-sr-x  2 saket saket 36864 Jan 25 03:09 inc
drwxr-sr-x  5 saket saket  4096 Jan 26 01:23 IsisDlm
-rw-r--r--  1 saket saket  6613 Dec  1 03:37 IsisPreferences
drwxr-sr-x  2 saket saket  4096 Jan 25 03:24 lib
-rw-r--r--  1 saket saket  2673 Dec  1 03:37 license.txt
drwxr-sr-x  2 saket saket  4096 Jan 26 02:30 make
-rw-r--r--  1 saket saket 17060 Dec 20 07:37 Makefile
drwxr-sr-x  2 saket saket  4096 Jan 25 03:36 scripts
drwxr-sr-x 33 saket saket  4096 Jan 25 03:05 src
drwxr-sr-x  3 saket saket  4096 Jan 25 03:05 templates
-rw-r--r--  1 saket saket   134 Jan 25 03:08 version


> head $ISISROOT/IsisPreferences
#######################################################
# This file allows the user to customize their Isis
# configuration.  See the Isis Preference Dictionary
# on our website isis.astrogeology.usgs.gov for a
# full description of each group.
########################################################

########################################################
# Customize elements of the user interface
#

#5 Updated by Saket Saket 11 months ago

bumping the thread for a fix.

#6 Updated by Stuart Sides 10 months ago

  • Target version changed from N/A to 3.5.1 (Sprint 1)

#7 Updated by Stuart Sides 10 months ago

Saket,
This looks like your environment is not pointing at ISIS correctly, but I'm not sure. Please post the output from:

echo $ISISROOT
echo $ISIS3DATA
which qview

#8 Updated by Saket Saket 10 months ago

Stuart,
Here are the command return

> echo $ISISROOT
/home/saket/ISIS/isis/
> echo $ISIS3DATA
/home/saket/ISIS/isis//../data
> which qview
/home/saket/ISIS/isis//bin/qview

#9 Updated by Stuart Sides 10 months ago

Saket,
Sorry this is proving to be difficult to track down in this remote manner.
The only way we can reproduce your error is when the ISISROOT environment variable does not point to a valid version of ISIS3.
Questions: Are you running the commands and qview from the same terminal window? Are you launching qview from a different shell?

Please post the results of:
echo $SHELL
echo $ISISROOT
echo $ISIS3DATA
which lowpass
lowpass from=xyz

#10 Updated by Saket Saket 10 months ago

Stuart,

Yes I run your query commands and qview command from the same window.

The results of you latest command queries are

> echo $SHELL
/bin/bash
> echo $ISISROOT
/home/saket/ISIS/isis/
> echo $ISIS3DATA
/home/saket/ISIS/isis//../data
> which lowpass
/home/saket/ISIS/isis//bin/lowpass
> lowpass from=xyz
terminate called after throwing an instance of 'Isis::IException'
  what():  **USER ERROR** The preference file $ISISROOT/IsisPreferences was not found or does not exist in Preference.cpp at 55.
Aborted (core dumped)
> qview
terminate called after throwing an instance of 'Isis::IException'
  what():  **USER ERROR** The preference file $ISISROOT/IsisPreferences was not found or does not exist in Preference.cpp at 55.
Aborted (core dumped)

These were all run in sequence from the same terminal.

Should i try doing a fresh install of ISIS? maybe a bug which got fixed in process somewhere.
Can you tell me how to do a complete uninstall of all configurations settings files etc.

#11 Updated by Stuart Sides 8 months ago

  • Target version changed from 3.5.1 (Sprint 1) to 3.5.2 (2017-01-31 Jan)

#12 Updated by Stuart Sides 7 months ago

We have been unable to reproduce this issue. Have you had any progress?

To uninstall ISIS3, remove the source/binary directories starting at ISISROOT, and remove your personal setting at $HOME/.Isis.

#13 Updated by Saket Saket 7 months ago

Yes,

I figured it to be a Ubuntu version related issue.

The installation works in Ubuntu or Lubuntu 12.04 but gives the issue, as described, in other versions.

#14 Updated by Stuart Sides 6 months ago

  • Status changed from In Progress to Closed

Closed for author. Not reproducible on supported Ubuntu 12.04.

Also available in: Atom PDF