Project

General

Profile

Bug #4883

pds2isis can't process a particular pds3 file

Added by Kaj Williams 7 months ago. Updated 1 day ago.

Status:
Resolved
Priority:
Normal
Category:
Applications
Target version:
Impact:

Will affect this error message in many of the *2isis applications.

Software Version:
Test Reviewer:

Description

Download two files:
http://pds-geosciences.wustl.edu/mgn/mgn-v-rss-5-gravity-l2-v1/mg_5201/topo/topogrd.dat
http://pds-geosciences.wustl.edu/mgn/mgn-v-rss-5-gravity-l2-v1/mg_5201/topo/topogrd.lbl

Then attempt a pds2isis command:
pds2isis FROM=topogrd.lbl TO=magellantopo.cub

It fails with the following message:
I/O ERROR Unknown label type in [topogrd.lbl].

As noted, pds2isis should not be able to process this PDS table file, but a better error message would be appropriate.

Suggestion: Add a check in ProcessImportPDS to throw a stacked IError when it can't find "Image", or "SpectralCube"

History

#1 Updated by Tammy Becker 7 months ago

  • Status changed from New to Acknowledged

#2 Updated by Robert Sucharski 7 months ago

The file listed in the post is not image data so ISIS cannot open the file. I was able to find an image file at, http://pds-geosciences.wustl.edu/mgn/mgn-v-rss-5-gravity-l2-v1/mg_5201/images/topogrd.*(lbl and img), that pds2isis was able to open and create an ISIS cube, however mapping keywords were not added to the labels(maybe having problems with "MAP_SCALE = "N/A").

#3 Updated by Stuart Sides 7 months ago

  • Description updated (diff)

#5 Updated by Stuart Sides 23 days ago

  • Status changed from Acknowledged to Assigned
  • Assignee set to Summer Stapleton
  • Target version set to 3.5.2 (2017-01-31 Jan)

Find the location of the reported error, and add:

It is possible the label file does not describe an image product (IMAGE, CUBE, or SPECTRALCUBE).

#6 Updated by Summer Stapleton 19 days ago

  • Status changed from Assigned to In Progress

#7 Updated by Summer Stapleton 19 days ago

  • Status changed from In Progress to Resolved
  • Impact updated (diff)

Changes in /work/project/isis/latest/m04883

This change is in ProcessImportPds.cpp, which is only used in the many 2isis applications, with the exception of pds2hideal.cpp and a kaguyasp2ascii.cpp, but confirmed that neither of these apps make a call to the affected method, so should not affect these applications.

#8 Updated by Kaj Williams 11 days ago

  • Status changed from Resolved to Feedback

Can't test this yet: when I run this from the command line on prog25, I get the following error:

[kewilliams@prog25 pds2isis]$ ./pds2isis FROM= /home/kewilliams/test/topogrd.lbl TO= /home/kewilliams/test/magellantopo.cub
./pds2isis: error while loading shared libraries: libisis3.5.2.so: cannot open shared object file: No such file or directory

#9 Updated by Summer Stapleton 4 days ago

  • Status changed from Feedback to Resolved

Hi Kaj, I'm not sure why you would be getting that error. (Just checked it and I am getting the same thing.) I will look into it. I just confirmed that you should still be able to run pds2isis from isis root without any issues. (Note that this is without the "./" ) The changes I made will be testable from there.

#10 Updated by Kaj Williams 1 day ago

Thanks, I now get the following:
[kewilliams@prog25 ~/test]$ pds2isis FROM=topogrd.lbl TO=magellantopo.cub
here?
I/O ERROR Unknown label type in [topogrd.lbl]. It is possible the label filedoes not describe an image.
[kewilliams@prog25 ~/test]$

Question: What does the "here?" mean in this context? Also there seems to be a space missing between "file" and "does".

Also available in: Atom PDF