Project

General

Profile

Bug #4904

Using multiple algorithm specs with filters in findfeatures does not work as expected

Added by Jesse Mapel 6 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Applications
Target version:
Impact:

The Scharr and Sobel filters now consume more memory during calculation. This should only impact processing of very large images. Matching a dozen 1024x1024 images will require about 12 more megaBytes of memory.

Software Version:
Test Reviewer:

Description

Using multiple algorithm spec with filters results in degradation of output after the first algorithm spec. All aglorithm specs share image data and the filters appear to be modifying that image data. Initial tests with the FAST detector and the Sobel filter show that different numbers of keypoints are detected when the same algorithm spec is repeated in the same run of findfeatures.

Using Sobel filter with the algospecfile:

fast/brief
fast/brief
fast/brief
fast/brief
fast/brief
fast/brief
fast/brief
fast/brief
fast/brief
fast/brief

results in the following number of keypoints detected in a Messenger image pair:

  Total Query keypoints:    58551 [58551]
  Total Query keypoints:    47072 [47072]
  Total Query keypoints:    38544 [38544]
  Total Query keypoints:    31882 [31882]
  Total Query keypoints:    26140 [26140]
  Total Query keypoints:    21431 [21431]
  Total Query keypoints:    17466 [17466]
  Total Query keypoints:    14250 [14250]
  Total Query keypoints:    11595 [11595]
  Total Query keypoints:    9599 [9599]

History

#1 Updated by Tammy Becker 6 months ago

  • Status changed from New to Acknowledged

#2 Updated by Tammy Becker 6 months ago

  • Target version set to 3.5.1 (2017-08-08 Aug)

#3 Updated by Stuart Sides 6 months ago

  • Target version changed from 3.5.1 (2017-08-08 Aug) to 3.5.1 (Sprint 1)

#4 Updated by Jesse Mapel 6 months ago

  • Status changed from Acknowledged to In Progress
  • Assignee set to Jesse Mapel

#5 Updated by Jesse Mapel 6 months ago

  • Status changed from In Progress to Resolved
  • Impact updated (diff)

Upon further investigation this ticket was being caused by the Scharr and Sobel filters erroneously applying a Guassian blur to the image data that was not being reset. Several warnings have been added to the code around image transformations to be careful with OpenCV matrices.

#6 Updated by Jesse Mapel 6 months ago

  • Subject changed from Specifying multiple filters in findfeatures does not work as expected to Using multiple algorithm specs with filters in findfeatures does not work as expected
  • Description updated (diff)

#7 Updated by Jesse Mapel 6 months ago

I've copied a algorithm specification file to the m04904 directory that can be used for testing. It has the same fast/brief algorithm set repeated several times. I tested with two images, /work/projects/messenger/Lev1/2011112/EW0211981114G.lev1.cub as the query, match image and /work/projects/messenger/Lev1/2012275/EW0257563816G.lev1.cub as the train, from, image. The images have different resolutions, so the fastgeom parameter needs to be set to true in order for the fast/brief algorithm set to work well.

#8 Updated by Robert Sucharski 6 months ago

I ran the application using Viking Orbiter and CTX images, and Total Query keypoints value remained the same for each run of the algorithm So things seem good.

#9 Updated by Jesse Mapel 6 months ago

  • Test Reviewer set to Robert Sucharski

#10 Updated by Jesse Mapel 5 months ago

  • Status changed from Resolved to Closed

#11 Updated by Stuart Sides 4 months ago

  • Target version changed from 3.5.1 (Sprint 1) to 3.5.1 (2017-08-08 Aug)

Also available in: Atom PDF