Project

General

Profile

Crash #4953

qview rotated rectangle tool crashes when selecting small areas

Added by Makayla Shepherd over 1 year ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Category:
Applications
Target version:
Impact:

SpatialPlotTool now allows for smaller selections without segfault. No other functionalities should be affected.

Software Version:
Test Reviewer:

Description

The qview spatial tool using rotated rectangle selection crashes when selecting a small area.

I've tested this on two cubes.
/usgs/cpkgs/isis3/testData/isis/src/base/apps/crop/tsts/sinu/input/mapsinu.cub - crashes when selecting 5 pixels or less
/usgs/cpkgs/isis3/testData/isis/src/base/apps/isis2pds/tsts/default/truth/ab102401.cub - crashes with 2 pixels or less


Related issues

Related to ISIS - Bug #5257: qview 2D spatial plot tool rotated rectangle reports incorrect information Closed

History

#1 Updated by Tammy Becker over 1 year ago

  • Status changed from New to Acknowledged

#2 Updated by Stuart Sides about 1 year ago

  • Status changed from Acknowledged to Assigned
  • Assignee set to Summer Stapleton
  • Target version set to 3.5.2 (2017-01-31 Jan)

#3 Updated by Summer Stapleton about 1 year ago

  • Status changed from Assigned to In Progress

#6 Updated by Summer Stapleton about 1 year ago

  • Status changed from In Progress to Resolved

#7 Updated by Summer Stapleton about 1 year ago

  • Status changed from Resolved to In Progress

#9 Updated by Makayla Shepherd about 1 year ago

  • Software Version set to 3.5.2 (2017-01-31 Jan)

#10 Updated by Summer Stapleton 12 months ago

  • Status changed from In Progress to Resolved

Fix built on Fedora25 and can be found at /work/project/isis/latest/m04953

Please confirm when selecting a space with just one pixel for either (or both) dimension(s) that expected values are returned from the tool!!

#11 Updated by Makayla Shepherd 11 months ago

  • Status changed from Resolved to Feedback

It is not crashing any more however I found another issue with the tool that may actually be the root cause of this crash. It looks like the tool is not calculating the area or average correctly. I will make a new ticket for the new issue. Please do not move forward on this ticket until you have talked to Stuart.

#12 Updated by Makayla Shepherd 11 months ago

  • Related to Bug #5257: qview 2D spatial plot tool rotated rectangle reports incorrect information added

#13 Updated by Summer Stapleton 11 months ago

  • Status changed from Feedback to In Progress

#14 Updated by Summer Stapleton 11 months ago

  • Status changed from In Progress to Resolved

#15 Updated by Summer Stapleton 11 months ago

  • Status changed from Resolved to In Progress

#16 Updated by Makayla Shepherd 10 months ago

The fix for this bug works a ticket was created for the other problem.

#17 Updated by Summer Stapleton 10 months ago

  • Status changed from In Progress to Resolved
  • Impact updated (diff)

#18 Updated by Makayla Shepherd 10 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF