Project

General

Profile

Bug #5262

qview - window selection issue

Added by Lynn Weller 10 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Applications
Target version:
Impact:

No expected impact outside of qviews tile tool

Software Version:
Test Reviewer:

Description

After tiling two images and linking them, if I click on the window bar of one of the images to select it to do something, it automatically enlarges to fit the screen - not the desired affect. It's a window bar issue for sure because if I have the find tool activated and click on the image, then the tiling holds. It's only when I click the window/title bar of an image view does the auto fit happen. Also of note is that after tiling (this was just w/ two images, so I don't know the affect of more), the title bar of the windows get weird - at least for the active one it's not all there. See the attachment to see what I mean.

Unfortunately I can't always reproduce the problem in this specific way, but there is one thing that will always get me there. See steps below after other notes.

I also opened a list of images and tiled those, but the problem wasn't there until I started to close some of the images, then re-tiled. Once I did that, the last image that had been active/focused had an incomplete title bar and when I clicked on any images title bar, it fit to screen. Note, my images were linked for these tests, but unlinking them help once the bad stuff started to happen. I can't always reproduce this either.

Another note - I opened a list of image, tiled them, then double-clicked on the title bar of one image to fit to screen. After that I clicked tile and the image that was expanded had no title bar. This I can always reproduce!

If I cascade after encountering the problem, then hit tile again, all title bars are present and I can click on images fine.

Steps to get to reproduce:
- have 2 images or more open; linked or unlinked, doesn't seem to matter
- select one image and expand to fit screen by either double-clicking on title bar or clicking in the window's maximize box in upper right
- select Tile from the Window menu
note that the image that had been maximized no longer has a title bar, or only part of it is present
- select the title bar of a different image (not even to maximize, just to select it to do something in it)
the window is maximized, which should not be the case

There are two lists of images under /work/users/lweller/Isis3Tests/Qview/Tiling/ to test with. The data are somewhere else on disk, but in a stable location. This problem appears whether I load images by list or individual filenames on the command line. There are also two cubes in the directory if you just want to look at those.

Another goofy thing - after going through the steps, I opened 2 new images and instead of bringing them as the smaller, standard size window it immediately expanded them.

I'm seeing this problem on astrovm4, isis3production2017-11-21. I run shells to astrovm4 via VMWare, but this is also happening via putty/xming.
I see this in older versions of isis (as far back as I can go before getting to public) maybe when the new tiling was introduced, but it does not happen in isis3.5.1 where the old tiling is available. But I can't recall this happening until just recently, so could it be possible that something the app uses was changed?

Edit - well, it did break when I tried isis3.5.1, but not the first time, whatever that means.

qview_tiling_problem.png View (214 KB) Lynn Weller, 2017-12-20 01:09 PM

History

#1 Updated by Lynn Weller 10 months ago

#2 Updated by Tammy Becker 10 months ago

  • Status changed from New to Acknowledged

#3 Updated by Stuart Sides 10 months ago

  • Target version set to 3.5.2 (2017-01-31 Jan)

#4 Updated by Cole Neubauer 9 months ago

  • Assignee set to Cole Neubauer

#5 Updated by Cole Neubauer 9 months ago

  • Status changed from Acknowledged to In Progress

#6 Updated by Cole Neubauer 9 months ago

  • Impact updated (diff)

setisis /work/projects/isis/latest/m05262/isis

Built for astrovm4

#7 Updated by Cole Neubauer 9 months ago

  • Test Reviewer set to Lynn Weller

#8 Updated by Cole Neubauer 9 months ago

  • Status changed from In Progress to Resolved

#9 Updated by Lynn Weller 9 months ago

  • Status changed from Resolved to Closed

Behaviour is now back to normal. Thanks!

Also available in: Atom PDF