Project

General

Profile

Bug #5299

qview can't find cocoa (hot or cold)

Added by paul schenk 8 months ago. Updated 6 months ago.

Status:
In Progress
Priority:
Normal
Assignee:
Category:
Installation
Target version:
Impact:
Software Version:
Test Reviewer:

Description

i have macbook pro 10.9.5 and an isis installation that is at least 4 years old.
tried calibrating new pds3 cassini files this week: ciss2isis worked but spiceinit said:

Error = "Can not find [BODY_FRAME_CODE] in text kernels"

so reinstalled isis to get latest. fine, but view says (same thing happened on Air but restored isis w backup):

This application failed to start because it could not find or load the Qt platform plugin "cocoa"
in "".
Available platform plugins are: cocoa, minimal, offscreen.
Reinstalling the application may fix this problem.

hmmmm....

History

#1 Updated by paul schenk 8 months ago

paul schenk wrote:

i have macbook pro 10.9.5 and an isis installation that is at least 4 years old.
tried calibrating new pds3 cassini files this week: ciss2isis worked but spiceinit said:

Error = "Can not find [BODY_FRAME_CODE] in text kernels"

so reinstalled isis to get latest. fine, but view says (same thing happened on Air but restored isis w backup):

This application failed to start because it could not find or load the Qt platform plugin "cocoa"
in "".
Available platform plugins are: cocoa, minimal, offscreen.
Reinstalling the application may fix this problem.

hmmmm....

forgot the install command:

rsync -azv --delete --exclude="presentation" --exclude="Developer" --exclude="Programmer" --exclude="dems" isisdist.wr.usgs.gov::x86-64_darwin_OSX .

#2 Updated by paul schenk 8 months ago

  • Project changed from PDS to ISIS
  • Subject changed from view can't find cocoa (hot or cold) to qview can't find cocoa (hot or cold)

i have macbook pro 10.9.5 and an isis installation that is at least 4 years old.
tried calibrating new pds3 cassini files this week: ciss2isis worked but spiceinit said:

Error = "Can not find [BODY_FRAME_CODE] in text kernels"

so reinstalled isis to get latest. fine, but view says (same thing happened on Air but restored isis w backup):

This application failed to start because it could not find or load the Qt platform plugin "cocoa"
in "".
Available platform plugins are: cocoa, minimal, offscreen.
Reinstalling the application may fix this problem.

hmmmm....

the install command:

rsync -azv --delete --exclude="presentation" --exclude="Developer" --exclude="Programmer" --exclude="dems" isisdist.wr.usgs.gov::x86-64_darwin_OSX .

#3 Updated by Tammy Becker 8 months ago

  • Category set to Installation
  • Status changed from New to Acknowledged

#4 Updated by Stuart Sides 8 months ago

  • Status changed from Acknowledged to In Progress
  • Assignee set to Stuart Sides
  • Target version set to N/A

Hi Paul,
Can you send me the contents of your $ISISROOT/version file please?
Stuart

#5 Updated by paul schenk 8 months ago

Stuart Sides wrote:

Hi Paul,
Can you send me the contents of your $ISISROOT/version file please?
Stuart

3.5.1.7995
2017-08-08 # Version date
v006 # 3rd party libraries version
stable # release stage (alpha, beta, stable)

#6 Updated by Stuart Sides 7 months ago

Paul,
To reply to this issue, make sure you are signed in (upper right corner) then click the "edit" button, add your text to the note and submit it.

I'm not able to reproduce this just yet, so I need some more info. Please post the results of:

echo $QT_PLUGIN_PATH
otool -L $ISISROOT/bin/qview

#7 Updated by paul schenk 7 months ago

i had to restore the older version yesterday, so this might not reflect the attempted update. this problem also occurred when i tried it on the mac air machine (this one is the macbook pro). so i wonder if its something to do wight he synch command i was using (posted above)

MBP-Schenk-13:icy schenk$ echo $QT_PLUGIN_PATH
/usr/local/isis3/isis/3rdParty/plugins

MBP-Schenk-13:icy schenk$ otool -L $ISISROOT/bin/qview
/usr/local/isis3/isis/bin/qview:
@rpath/lib/libisis3.4.13.dylib (compatibility version 3.4.0, current version 3.4.13)
@rpath/3rdParty/lib/libz.1.dylib (compatibility version 1.0.0, current version 1.2.8)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 169.3.0)
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices (compatibility version 1.0.0, current version 45.0.0)
@rpath/3rdParty/lib/QtXmlPatterns.framework/Versions/4/QtXmlPatterns (compatibility version 4.8.0, current version 4.8.5)
@rpath/3rdParty/lib/QtXml.framework/Versions/4/QtXml (compatibility version 4.8.0, current version 4.8.5)
@rpath/3rdParty/lib/QtNetwork.framework/Versions/4/QtNetwork (compatibility version 4.8.0, current version 4.8.5)
@rpath/3rdParty/lib/QtSql.framework/Versions/4/QtSql (compatibility version 4.8.0, current version 4.8.5)
@rpath/3rdParty/lib/QtGui.framework/Versions/4/QtGui (compatibility version 4.8.0, current version 4.8.5)
@rpath/3rdParty/lib/QtCore.framework/Versions/4/QtCore (compatibility version 4.8.0, current version 4.8.5)
@rpath/3rdParty/lib/QtSvg.framework/Versions/4/QtSvg (compatibility version 4.8.0, current version 4.8.5)
@rpath/3rdParty/lib/QtTest.framework/Versions/4/QtTest (compatibility version 4.8.0, current version 4.8.5)
@rpath/3rdParty/lib/QtWebKit.framework/Versions/4/QtWebKit (compatibility version 4.9.0, current version 4.9.4)
@rpath/3rdParty/lib/QtOpenGL.framework/Versions/4/QtOpenGL (compatibility version 4.8.0, current version 4.8.5)
@rpath/3rdParty/lib/qwt.framework/Versions/6/qwt (compatibility version 6.0.0, current version 6.0.2)
@rpath/3rdParty/lib/libxerces-c-3.1.dylib (compatibility version 0.0.0, current version 0.0.0)
@rpath/3rdParty/lib/libgeotiff.2.dylib (compatibility version 4.0.0, current version 4.0.0)
@rpath/3rdParty/lib/libtiff.5.dylib (compatibility version 8.0.0, current version 8.0.0)
@rpath/3rdParty/lib/libdsklib.dylib (compatibility version 0.0.0, current version 0.0.0)
@rpath/3rdParty/lib/libcspice.dylib (compatibility version 0.0.0, current version 0.0.0)
@rpath/3rdParty/lib/libgeos-3.4.2.dylib (compatibility version 0.0.0, current version 0.0.0)
@rpath/3rdParty/lib/libgeos_c.1.dylib (compatibility version 10.0.0, current version 10.2.0)
@rpath/3rdParty/lib/libgsl.0.dylib (compatibility version 18.0.0, current version 18.0.0)
@rpath/3rdParty/lib/libgslcblas.0.dylib (compatibility version 1.0.0, current version 1.0.0)
@rpath/3rdParty/lib/libprotobuf.8.dylib (compatibility version 9.0.0, current version 9.0.0)
@rpath/3rdParty/lib/libkdu_a63R.dylib (compatibility version 0.0.0, current version 0.0.0)
@rpath/3rdParty/lib/libcholmod.dylib (compatibility version 0.0.0, current version 0.0.0)
@rpath/3rdParty/lib/libamd.dylib (compatibility version 0.0.0, current version 0.0.0)
@rpath/3rdParty/lib/libcolamd.dylib (compatibility version 0.0.0, current version 0.0.0)
@rpath/3rdParty/lib/libcamd.dylib (compatibility version 0.0.0, current version 0.0.0)
/System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate (compatibility version 1.0.0, current version 4.0.0)
@rpath/3rdParty/lib/libhdf5.8.dylib (compatibility version 9.0.0, current version 9.0.0)
@rpath/3rdParty/lib/libhdf5_hl.8.dylib (compatibility version 9.0.0, current version 9.0.0)
@rpath/3rdParty/lib/libhdf5_cpp.8.dylib (compatibility version 9.0.0, current version 9.0.0)
@rpath/3rdParty/lib/libhdf5_hl_cpp.8.dylib (compatibility version 9.0.0, current version 9.0.0)
@rpath/3rdParty/lib/libsuperlu_4.3.dylib (compatibility version 0.0.0, current version 0.0.0)
/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib (compatibility version 1.0.0, current version 1.0.0)
/usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current version 56.0.0)

#8 Updated by paul schenk 6 months ago

any progress on this? I'm going to have to update to get the latest cassini kernels

#9 Updated by paul schenk 6 months ago

on an unrelated issue, i wanted to create a large file, got this
USER ERROR The cube you are attempting to create [/Volumes/skank2b/icy/pmap_cyl_VHR_Mcolor2-k3201.cub] is [13GB]. This is larger than the current allowed size of [12GB]. The cube dimensions were (S,L,B) [36814, 23851, 4] with [4] bytes per pixel. If you still wish to create this cube, the maximum value can be changed in the file [~/.Isis/IsisPreferences] within the group CubeCustomization, keyword MaximumSize.
edited the file, verified it, but got same answer...

Also available in: Atom PDF