Project

General

Profile

Bug #5329

tgocassisunstitch outputs (at least some) blue frames are as all nulls

Added by Kristin Berry 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
API
Target version:
-
Impact:

Minimal - Affected applications include tgocassisunstitch.

Software Version:
Test Reviewer:

Description

tgocassisunstitch outputs (at least some) blue frames are as all nulls

History

#1 Updated by Adam Goins 7 months ago

  • Category set to API
  • Status changed from New to In Progress

#2 Updated by Adam Goins 7 months ago

  • Status changed from In Progress to Resolved
  • Impact updated (diff)

This was being caused by tgocassisunstitch not considering the sample offsets of framelets inside the stitched cube. The blue framelet in this case was located in the middle of the output cube, but when unstitched into a framelet via ProcessByLine we were starting from the left hand side of the stitched cubes and writing those pixel DN's (null pixels because the framelet was in the middle of the stitched cube) in a linear fashion to the output cube.

tgocassisunstitch was modified to include this sample offset when unstitched a framelet.

#3 Updated by Kristin Berry 7 months ago

  • Status changed from Resolved to Closed

Tested by Jesse.

Also available in: Atom PDF