Project

General

Profile

Bug #5338

Cassini RADAR BIL* files

Added by Shannon Shannon 2 months ago. Updated 10 days ago.

Status:
Resolved
Priority:
High
Category:
Applications
Target version:
-
Impact:

N/A

Software Version:
Test Reviewer:

Description

Hi,

I'm trying to ingest certain BIDR files, specifically the BIL* files listed below.

https://pds-imaging.jpl.nasa.gov/data/cassini/cassini_orbiter/CORADR_0100/DATA/BIDR/BILQI69N342_D100_T019S01_V03.ZIP
https://pds-imaging.jpl.nasa.gov/data/cassini/cassini_orbiter/CORADR_0087/DATA/BIDR/BILQI80N051_D087_T016S01_V02.ZIP

However, when I do pds2isis, I get the following error:

pds2isis from=BILQI69N342_D100_T019S01_V03.IMG to=T19_seg1_BIL.cub
PROGRAMMER ERROR Unable to find a translation value for [CorePixelType, UNSIGNED INTEGER] in file [/Users/mackesm1/isis3/isis/../data/base/translations/pdsImage.trn].

I've just updated to the latest ISIS version. Any hints what the problem is?

Thanks!

History

#1 Updated by Tammy Becker about 2 months ago

  • Category set to Applications
  • Status changed from New to Acknowledged

#2 Updated by Christopher Combs 15 days ago

  • Assignee set to Christopher Combs

#3 Updated by Christopher Combs 15 days ago

  • Status changed from Acknowledged to In Progress

#4 Updated by Christopher Combs 15 days ago

  • Status changed from In Progress to Resolved
  • Impact updated (diff)

The issue was two missing keywords in the translation file usgs/cpkgs/isis3/data/base/translations/pdsImage.trn:
UNSIGNED_INTEGER was supported, but "UNSIGNED INTEGER" was not

This is available for testing/viewing at: /work/projects/isis/latest/m05338

This ticket does not require any changes to the ISIS3 repo

#5 Updated by Makayla Shepherd 10 days ago

Hi Shannon,

pds2isis should probably work to ingest your data (once we get the translation files updated), and it will propagate mapping group for the oblique cylindrical projection. If you use pds2isis you could display your images and possibly use map2map if you have the correct information in the Mapping group.

However, we do not have a camera model for Cassini RADAR and the specific instrument keywords will not be propagated. The impact of not having a camera model for this type of projected product is that ISIS won't be able to report anything but Lat/Lon.

Also available in: Atom PDF