Project

General

Profile

Bug #5350

qview ingests .lbl files as cubelists, causing them not to be ingested.

Added by Adam Goins 7 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Christopher Combs
Category:
API
Target version:
-
Impact:
Software Version:
Test Reviewer:

Description

qview currently treats any file that does not have a .cub or .cube extension as a cubelist and attempts to ingest it as such.
This makes .lbl uningestable because it will read it as a cubelist and throw errors immediately.

The code for this is located in Workspace.cpp

Workspace::addCubeViewport(QString cubename).

qview should ingest a filename and attempt to open it as a cube, if it can't then it should attempt to ingest it as a cubelist, and if that fails then an error should be thrown.

History

#1 Updated by Tammy Becker 7 months ago

  • Status changed from New to Acknowledged

#2 Updated by Makayla Shepherd 7 months ago

What are you trying to accomplish when trying to open a .lbl in qview? Do you want it to open the corresponding cube?

#3 Updated by Adam Goins 6 months ago

Yes. when ingesting the .lbl file it should open the corresponding cube. This behavior was present prior to ISIS 3.5.2 release. This change was caused by the fix for ticket #5099 where we added the ability to ingest cube lists directly into qview.

#4 Updated by Christopher Combs 6 months ago

  • Assignee set to Christopher Combs

It seems that the old way of handling running qview on labels is in Cube.cpp: in the open() method we check for a "^Core" keyword and open the file associated with it.

We can return to this by adding ".lbl" to the list of checks before assuming a cube list (in Workspace.cpp), but it will not cover all types of labels, such as the labels created using catlab.

This is available for viewing/testing at /work/projects/isis/latest/m05350,
two test files are available there (f319b18.lbl created from catlab, and W1591159850_1_cal.lev2.detached.ccw180.lbl which has "^Core").

#5 Updated by Christopher Combs 6 months ago

  • Status changed from Acknowledged to In Progress

#6 Updated by Christopher Combs 6 months ago

  • Status changed from In Progress to Blocked

Blocked: Do we want to return to the previous functionality of only supporting lbls that have "^Core" Keywords, or do we want to update cube to handle all types of lbl files? (Not all lbl's have keywords that point to their cube)

#7 Updated by Makayla Shepherd 5 months ago

  • Status changed from Blocked to Feedback

We should just return to the old functionality.

If we want to support all label files a different Feature ticket can be added.

#8 Updated by Christopher Combs 5 months ago

  • Status changed from Feedback to Resolved

#9 Updated by Adam Goins 5 months ago

  • Status changed from Resolved to Closed

Looks good!

Also available in: Atom PDF