Project

General

Profile

Bug #5419

Qnet causes error popup when creating a point with blank point filter selected

Added by Adam Goins 6 months ago. Updated 13 days ago.

Status:
Acknowledged
Priority:
Normal
Assignee:
-
Category:
Applications
Target version:
-
Impact:
Software Version:
Test Reviewer:

Description

When you set the qnet filter option to cube and filter the list, If you change the filter back to 'point' and create a new point on an open cube it will throw a "please enter a search value" filter error
because it thinks you're trying to filter by points because the point tab is open.
This causes an impediment with testing and is related to tickets 2266 and 2267

Steps to reproduce:
open cubelist / controlnet.
switch filter type to cube
filter the cubes by number of points associated with the cube (enter an arbitrary number, it doesn't matter)
open a cube
switch navigation type to points
create a point on the cube you opened

You'll see an error popup because when createPoint() is called it calls filter() and because the 'point' tab is selected at that time it thinks you're trying to filter by points, but no value is entered.


Related issues

Related to ISIS - Bug #2266: qnet - cube list not re-filtering when creaing a new point and navigating by points Feedback
Related to ISIS - Bug #2267: qnet - when navigating by cubes, new point created does not show up after switching navigation type to points Feedback

History

#1 Updated by Adam Goins 6 months ago

  • Related to Bug #2266: qnet - cube list not re-filtering when creaing a new point and navigating by points added

#2 Updated by Adam Goins 6 months ago

  • Related to Bug #2267: qnet - when navigating by cubes, new point created does not show up after switching navigation type to points added

#3 Updated by Makayla Shepherd 6 months ago

  • Status changed from New to Acknowledged

Also available in: Atom PDF