Project

General

Profile

Bug #5558

Unable to initialize camera model on LROC images

Added by Catherine Neish 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Impact:
Software Version:
Test Reviewer:

Description

Hi there,

I just ran spiceinit on an LROC image (M1244116426LE.IMG), and received the following error:

Error = "The ck rotation from frame -85600 can not be
found due to no pointing available at requested
time or a problem with the frame"

ERROR Unable to initialize camera model.

I recently updated all the kernels for LRO, so this is not the issue. Is there any way to initialize the camera model for this image, or is it impossible to do so with the existing kernels? The image was acquired on March 14, 2017.

Thanks, Catherine

History

#1 Updated by Lynn Weller 4 months ago

Hi Catherine,

I tried working with your image and was successful running it through spiceinit. Since I am an isis3 user here at astro, I sort of have everything I need up to date and at my fingertips, so it's possible the kernel you need is not available yet, but I can't be sure.

Silly question - did you run lronac2isis to ingest your image? I want to be sure it was ingested properly.

Here are my steps (I'm pointing to our local PDS access):
lronac2isis from=/pds_san/PDS_Archive/Lunar_Reconnaissance_Orbiter/LROC/EDR/LROLRC_0030/DATA/ESM3/2017073/NAC/M1244116426LE.IMG to=M1244116426LE.cub
spiceinit from=M1244116426LE.cub

Please double check your steps and let us know what version of isis you are working with.
Also, we are migrating isis issues to github and someone may respond asking you to add your issue to the isis3 issues page.

#2 Updated by Catherine Neish 4 months ago

Hi Lynn,

Yes, I always use lronac2isis to ingest my images. This is the first time I've run into a problem. Here is the version of ISIS I'm using:

3.6.0 # Public version number
10-26-2018 # Release date
beta # release stage (alpha, beta, stable)

I noticed that the image is not available on the LRO Quickmap either. Perhaps the kernel that is needed is not publicly available.

Thanks, Catherine

#3 Updated by Lynn Weller 4 months ago

Please make sure you have the kernels I picked up when I ran spiceinit, and if not try the rsync command again. If after doing so you still don't have these kernels let us know.

And no, without spiceinit, you can not initialize the camera model (as far as I know).

Group = Kernels
NaifFrameCode = -85600
LeapSecond = $base/kernels/lsk/naif0012.tls
TargetAttitudeShape = ($base/kernels/pck/pck00009.tpc,
$lro/kernels/pck/moon_080317.tf,
$lro/kernels/pck/moon_assoc_me.tf)
TargetPosition = (Table,
$lro/kernels/tspk/moon_pa_de421_1900-2050.bpc,
$lro/kernels/tspk/de421.bsp)
InstrumentPointing = (Table,
$lro/kernels/ck/soc31_2017073_2017074_v01.bc,
$lro/kernels/ck/moc42r_2017059_2017091_v01.bc,
$lro/kernels/fk/lro_frames_2014049_v01.tf)
Instrument = $lro/kernels/ik/lro_lroc_v18.ti
SpacecraftClock = $lro/kernels/sclk/lro_clkcor_2019030_v00.tsc
InstrumentPosition = (Table,
$lro/kernels/spk/fdf29r_2017060_2017091_v01.b-
sp)
InstrumentAddendum = $lro/kernels/iak/lro_instrumentAddendum_v04.ti
ShapeModel = $base/dems/ldem_128ppd_Mar2011_clon180_radius-
pad.cub
InstrumentPositionQuality = Reconstructed
InstrumentPointingQuality = Reconstructed
CameraVersion = 2
End
Group

#4 Updated by Catherine Neish 4 months ago

Hi Lynn,

The only kernel I am missing is $lro/kernels/ck/soc31_2017073_2017074_v01.bc. Only the kernels from 2019 are available when you rsync (i.e., soc31_2019002_2019003_v01.bc). I just updated it, and it is still not there.

Best, Catherine

#5 Updated by Lynn Weller 4 months ago

Thanks Catherine!

I've passed on the info to the developer who tends to the kernels and the server and let him take over from there.
If he has no objections I'll upload your missing kernel to this site so you can at least work with that image (and if it's not too big).

Odd - I can't find that file under our repository despite that fact that it got loaded. I don't know what that means. For the moment, there is nothing I can upload to help you along.

#6 Updated by Lynn Weller 4 months ago

Sorry for the confusion, but as it turns out my IsisPreferences files was pointing to a local data area that contained daily kernels that I was able to pick up and successfully spice my image with, but is not available otherwise.
I reran the file not pointing to my special area and spiceinit fails confirming your problem. We will continue to look into this as it is odd that a daily kernel existed for this file at one time but is not included in the yearly kernels.

We made sure we have what asu has and still get a failure, so there is likely an accidental omission on there end.

Thanks for bringing this to our attention and we will let you know when/if it is resolved.

#7 Updated by Stuart Sides 4 months ago

  • Status changed from New to Acknowledged
  • Assignee set to Stuart Sides
  • Target version set to N/A

Hi Catherine,
We are missing one of the SPICE CKs for that image. I've contacted LROC and will post or fix this as soon as we hear back.
Thanks for posting,
Stuart

#8 Updated by Catherine Neish 4 months ago

Thank you Lynn and Stuart for your help on this.

Best, Catherine

#9 Updated by Stuart Sides 3 months ago

  • Status changed from Acknowledged to Resolved

Hi Catherine,
LROC fixed this and we have the missing file on the rsync servers. Please go ahead and update your LRO data and try spiceinit again.

Missing file:
$ISIS3DATA/lro/kernels/ck/lrolc_2017059_2017091_v01.bc

Stuart

#10 Updated by Stuart Sides 3 months ago

  • Tracker changed from Question to Bug

Also available in: Atom PDF