Project

General

Profile

Bug #607

grid - outline=true fills half my mosiac with HRS pixels

Added by Lynn Weller over 7 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Steven Lambright
Category:
-
Target version:
-
Impact:
Software Version:
Test Reviewer:

Description

I am trying to add some grid lines to a mosaic and ensure in the end the image/mosaic itself is outlined as well, but I keep running into problems. I don't know how to get this program to do what I need it to do. The best I could do was get grid lines without the image outline because when I add image outline the resulting product is an image where half of the image data is replace with HRS.

Steps to reproduce:

Test data available under /work/users/lweller/Isis3Tests/Grid/

The input mosaic has an equatorial projection, lat range (-65,65) and lon range (0,360). I'm trying get grid lines every 10 degrees in lat/lon. For the latitude, I want the grid at 0 lat, then every 10 degrees from there - I'm starting at lat -70.0 to ensure this (actually, I get the same results when I set baselat to 0.0).

Here's how I run it to get grid lines the way I like, but no image outline (well, I get a line along the left and top edge of my mosaic, but not the bottom or right edge):

grid from=messenger_full.cub to=messenger_full_grid.cub \
outline=false boundary=true \
baselat=-70.0 baselon=0.0 latinc=10 loninc=10 linewidth=3

What's bizarre is I have a reduced version of this mosaic that when run the same way, gets the outline, even when I don't ask for it (see messenger_reduced_grid.cub). What's going on there? However, upon further inspection, I see there are no longitudinal grid lines between 0 and 70. Hmm.

When I run the full.cub version through grid again, this time asking for outline=true, half the image is hrs:

grid from=messenger_full.cub to=messenger_full_grid_outline.cub \
outline=true boundary=true \
baselat=-70.0 baselon=0.0 latinc=10 loninc=10 \
minlat=-65.0 maxlat=65.0 minlon=0.0 maxlon=360.0 linewidth=3

How do I make this work properly?


Related issues

Related to ISIS 2 Ports - Feature #220: ISIS 2 applications to be ported to ISIS 3 Acknowledged

History

#1 Updated by Steven Lambright over 7 years ago

I am able to reproduce what you're doing, and setting baselat=0 seems to give you some of your lines back with the reduced file. This is definitely a bug.

#2 Updated by Steven Lambright over 7 years ago

I found the missing lines problem. I'm still looking for the "half the image is hrs" problem - this will take longer due to the larger file size.

#3 Updated by Steven Lambright over 7 years ago

I think I found the HRS fill problem.

Assuming I found the actual problems,

The missing lines problem was due to confusing the lat/lon in some calculations.
The half-HRS problem was due to confusing the sample/line in some calculations.

I am preparing to give you an Isis version for testing.

#4 Updated by Steven Lambright over 7 years ago

I have added a reduced version of your file and a run exhibiting both problems to the automated Isis testing suite.

By noon (2011-12-08) this will be ready for testing. Please use this Isis version to test my changes:
/work/projects/isis/latest/000607/isis

FYI I've put the test cases you described into:
/work/projects/isis/latest/000607/test

If everything works, go ahead and close this ticket and I will make sure the fix makes it into production.

#5 Updated by Steven Lambright over 7 years ago

Two problems found and fixed.

#6 Updated by Lynn Weller over 7 years ago

This has been tested under /work/projects/isis/latest/000607
and works as expected. In addition to the user tests you set up, I also did some runs with variations on boundary and outline being set to true/false to see if the results were as expected. Everything looks ok for these data.

#7 Updated by Steven Lambright over 7 years ago

If all goes well, this fix will be in beta tomorrow and in production on Saturday.

Also available in: Atom PDF